Opened 10 years ago

Closed 5 years ago

Last modified 4 years ago

#4968 closed Bug report (rejected)

Message Log contents spill over, displaying over Quick Connect bar and Toolbar

Reported by: J. A. Owned by:
Priority: high Component: FileZilla Client
Keywords: message log overwrite spill over display error quick connect toolbar Cc: yehuda@…, john@…, gmjs@…
Component version: Operating system type: Windows
Operating system version: 7, 32/64-bit HomePrem/Prof/Ent/Ult

Description

Messages are not properly constrained to the Message Log area. They spill over and are displayed on top of the Quickconnect bar and Toolbar (directly above the Message Log area) as new messages are produced. (See screenshot)

Version 3.3.0 and previous versions affected.
Windows 7 (64 bit) on Intel Core Duo

Attachments (2)

filezilla_log_display_error.png (9.6 KB) - added by J. A. 10 years ago.
Screenshot of typical symptom
FileZilla, MovingToolbars.png (103.3 KB) - added by Wes 10 years ago.
Filezilla, Moving toolbars

Download all attachments as: .zip

Change History (33)

Changed 10 years ago by J. A.

Screenshot of typical symptom

comment:1 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

What is your graphics card?

comment:2 Changed 10 years ago by J. A.

Status: moreinfonew

Intel 965 GMA

comment:3 Changed 10 years ago by J. A.

...with latest driver 8.15.10.1930.

There have been other problems with various recent versions of this driver under Windows 7 (repeated crashing leading to BSOD)

comment:4 Changed 10 years ago by Wes

Keywords: quick connect toolbar added
Operating system version: 7, 64-bit Ultimate7, 64-bit Ultimate, Home Premium

This also happens for me with Win7 Home Premium, Video: Intel G41 Express Chipset - driver v8.15.10.1872, FileZilla v3.3.1. Uploaded new graphic to show the quick-connect toolbar is being overlaid with the status messages.

Changed 10 years ago by Wes

Filezilla, Moving toolbars

comment:7 Changed 9 years ago by YK

Cc: yehuda@… added

comment:8 Changed 9 years ago by Tim Kosse

Status: newmoreinfo

Please try the latest drivers for your Intel graphics chip. I believe 15.17.7 or so is current.

comment:9 Changed 9 years ago by J. A.

Status: moreinfonew

It appears I am using driver 8.15.10.1867 now. I'm not seeing the problem anymore in filezilla 3.3.2.1.

comment:10 Changed 9 years ago by YK

My graphics card is Intel 965 GMA.
according to Intel, the latest drivers are 8.15.10.1930 (as of 7/18/2010) and according to device manager that is what I have.
I am still having this problem periodically (screenshots and more in my original ticket #5283)

comment:11 Changed 9 years ago by John McCabe

Cc: john@… added

comment:12 Changed 9 years ago by Tim Kosse

Status: newmoreinfo

comment:13 Changed 9 years ago by YK

Status: moreinfonew

15 is the package version.
If you open the readme (http://downloadmirror.intel.com/18228/eng/installation_readme_win7_64.txt) you can see the actual driver versions that are in the download package.

comment:14 Changed 9 years ago by clipper87

Cc: clipper87@… added
Operating system version: 7, 64-bit Ultimate, Home Premium7, 64-bit Prof

I have the same problem with v3.3.3 on windows 7 prof 64 bit / Intel 965 driver version 8.15.10.1930

comment:15 Changed 9 years ago by John McCabe

Operating system type: Windows

ticket:5283 was marked as a duplicate of this. There is some more info in there that could be of use.

The Inspiron 1545 I have seen this issue on was using the latest drivers for Intel GMA4500MHD graphics.

Last edited 4 years ago by Alexander Schuch (previous) (diff)

comment:16 in reply to:  description Changed 8 years ago by Tim Van Holder

Same issue with 3.5.0 on Win7 Pro x64.

Machine: Dell Latitude E5510
CPU: Intel Core i7 M 640.
GFX: "Intel HD Graphics", driver version 8.15.10.2182.

Seems to be related to getting a large chunk of text at once. On an initial connect the FEAT command returns a lot of lines:

Command: FEAT
Response: 211-Features:
Response: LANG fr-FR.UTF-8;fr-FR;zh-CN.UTF-8;zh-CN;zh-TW.UTF-8;zh-TW;en-US.UTF-8;en-US*;bg-BG.UTF-8;bg-BG;it-IT.UTF-8;it-IT;ja-JP.UTF-8;ja-JP;ko-KR.UTF-8;ko-KR;ru-RU.UTF-8;ru-RU
Response: MDTM
Response: MFMT
Response: TVFS
Response: UTF8
Response: AUTH TLS
Response: MFF modify;UNIX.group;UNIX.mode;
Response: MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
Response: PBSZ
Response: PROT
Response: SITE MKDIR
Response: SITE RMDIR
Response: SITE UTIME
Response: SITE SYMLINK
Response: REST STREAM
Response: SIZE
Response: 211 End

and that's when the overflow happens. A disconnect+connect to the same server during the same session doesn't send a FEAT anymore and also does not (re)overflow the message log.

comment:17 Changed 8 years ago by gmjs

Cc: gmjs@… added
Operating system type: Windows
Operating system version: 7, 64-bit Prof7, 32/64-bit HomePrem/Prof/Ent/Ult

This bug is only displayed when running the Windows 'Aero' interface. Switching this off (using Basic or Classic theme) may be a suitable workaround until a fix becomes available.

comment:18 Changed 8 years ago by John McCabe

Useful information about Aero but, as it's the default theme on most Win7 installations (with enough graphics power), it seems that a more appropriate workaround is to ignore this problem until a fix becomes available. It looks awful but doesn't do any harm and the inconvenience of choosing a different theme just to run FileZilla seems a bit excessive.

comment:19 in reply to:  18 ; Changed 8 years ago by Tim Van Holder

Replying to jmccabe:

Completely turning off Aero is indeed not a workaround, but you can achieve the same result (and no spillover) by doing the following in Windows 7:

  • Right-Click the FileZilla shortcut and select Properties
  • Select the Compatibility tab
  • Check the "Disable desktop composition" checkbox
  • Click Apply or OK

Obviously this assumes an English version of Windows; menus and labels will differ for other languages.
I don't think you need to have admin powers to do this, but you might.

Once this is done, Windows will switch to a simplified Aero when you run FileZilla, and the spillover does not occur this way (at least on my machine).

That to me is an acceptable workaround until a fix is implemented (so was ignoring it, of course).

comment:20 Changed 7 years ago by Alexander Schuch

A duplicate with more links duplicates can be found at #7799.

comment:21 Changed 7 years ago by Alexander Schuch

Summary: Message Log contents spill over, displaying over Quickconnect bar and ToolbarMessage Log contents spill over, displaying over Quick Connect bar and Toolbar

comment:22 in reply to:  19 Changed 7 years ago by Chris Ciolli

A couple of additional workarounds...

  • Select the Edit menu and click Settings
  • Select Interface page
  • Change the Message log position to anything BUT "Above the file lists"

OR (not great, but restores the Toolbars)

  • Select the View menu and turn the Toolbar off
  • Select the View menu again and turn the Toolbar on

This will have to be done each time the Message log spills over

comment:23 Changed 7 years ago by Alexander Schuch

According to #8357, "This only happens with the OpenCrystal theme. With every other theme, this does not happen."

comment:24 in reply to:  23 Changed 7 years ago by Tim Van Holder

Replying to ci-dev:

According to #8357, "This only happens with the OpenCrystal theme. With every other theme, this does not happen."

Not true. I re-enabled desktop composition and tried with various themes (Classic, Blukis, OpenCrystal) in 3.6.0.2 and all showed the problem.

comment:28 Changed 6 years ago by Hartmut Hinckel

I changed my PC to a win 7 32bit mini Desktop Acer, an now I have the same problem (see the first attachment). My Old-System was Win XP sp3.

FileZilla info:

FileZilla Client


Version: 3.7.3

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2013-08-07
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.12
GnuTLS: 3.1.11
SQLite: 3.7.16.2

Operating system:

Name: Windows NT 6.1 (build 7601, Service Pack 1)
Version: 6.1
Platform: 32 bit system

comment:29 Changed 6 years ago by clipper87

Cc: clipper87@… removed

comment:31 in reply to:  30 Changed 6 years ago by Hartmut Hinckel

Replying to masjeck:

Most likely explanation is that you have a broken virus scanner that scans everything before it allows FileZilla to merely query file attributes.

I have avira-Antivirus and a tested with all disabled including firewall.
No better results.
If I start my Filezilla it looks ok. But when I connect a ftp-site the log/messages overwrites all the menue and the quickconnect line.
If I start filezilla and put the log off, it is ok. Than I activate the log later result: no overwrites, all menus / log looks perfekt!

I hope someone can find a bug.

comment:32 Changed 5 years ago by robrob70

Priority: normalhigh

I've been following this issue for a long time, there are several tickets for this. But this seems to be the original ticket.

The problem still occurs in Windows 7, I've read in other tickets that they say its a windows problem, if that were true than this issue would occur in lots of other applications, FTP or otherwise. But this is the only program that does this, please please fix it.

It is very easy to reproduce the problem, just install on a Windows 7 machine, set your Windows Zoom to Medium 125% and viola, you will see this problem. Its very annoying, but I love Filezilla, but its been years, please fix this.

comment:33 Changed 5 years ago by Jason

HP 620 (Intel Series 4 chipset)
Windows 7, X86 (32 bit)
Intel Driver 8.15.10.2057
Aero Theme

Issue happens in Filezilla does not happen in other software.

##TEST 1##
Closed Filezilla, changed theme to 'Windows 7 Basic', re-opened Filezilla
Result: This fixes the log overwriting over toolbar. It stilll shows odd behaviour; whilst resizing window 'Queue' text flickers over QuickConnect button. Text boxes

on quick connect toolbar also flicker.

Re-Activated Aero, and issue with log messages reappeared.

##TEST 2##

Installed Intel Chipset Driver 10.0 and rebooted. Issue remains.

##TEST 3##

Changed Windows Textsize to 125% and message log issue is gone, but get flicker on window resize like in Basic Theme mode.

Cannot keep this text size as makes windows icons way too large.

Tried Custom, 101% with Win XP Style dpi scaling enabled, issue occurs.
Tried Custom, 101% with Win XP Style dpi scaling disabled, issue occurs.

##TEST 4##

Right click FileZilla icon, Properties
on Compatibility tab...

disable visual theme
RESULT FAIL Issue still occurs

##TEST 5##

Resize / drag message log a bit bigger, Close and re-open.
Issue goes away.

Resize / drag Message log back to minimum normal size, Close and re-open
ISsue Re-appears


##WORKAROUND##

The issue only happens when the message log is at it's minimum (and default) size. I just simply drag it to make it around 10 pixels or so bigger.

This works for Me, Be handy to see if this works for everyone, as if so the fix could simply be making the default message size a few pixels bigger

comment:34 in reply to:  33 Changed 5 years ago by Jason

I was previously using 3.9 on the machine in question. I have, this evening, upgraded that machine to Filezilla 3.10. This issue appears to be fixed in 3.10 for me. I will continue to monitor.

Replying to cpugenesis:

HP 620 (Intel Series 4 chipset)
Windows 7, X86 (32 bit)
Intel Driver 8.15.10.2057
Aero Theme

comment:35 Changed 5 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is a bug in Intel graphics drivers. Contact Intel for assistance.

Note: See TracTickets for help on using tickets.