Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4967 closed Bug report (fixed)

Trying to close busy tab freezes tab area display/interaction

Reported by: Steven Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP Home Edition SP3

Description

FileZilla Client 3.3.0

This problem has to do with closing a tab while it is still attempting to connect to the server.

Steps To Reproduce:

  1. Open A New Tab
  2. Connect to a server
  3. While still connecting (before first directory listing) attempt to close the tab. You should get a confirmation dialog since the tab is active.
  4. Click "No" on this confirmation dialog
  5. Attempt to use FileZilla.

In my experience, this freezes the tab area, while the rest of the UI works just fine. Even while the dialog is still open, the tab area is frozen until you hit "Yes", and remains frozen even after hitting "No". I don't even get the first directory listing.

Change History (2)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Thanks, will be fixed in the next version.

comment:2 Changed 10 years ago by Tim Kosse

Summary: Trying to close active tab freezes tab area display/interactionTrying to close busy tab freezes tab area display/interaction
Note: See TracTickets for help on using tickets.