Opened 10 years ago

Last modified 5 years ago

#4166 reopened Feature request

Filezilla isn't a file management tool

Reported by: Matthias Seifert Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

This bug report is (in some way) based on tickets submitted before, e.g.: #1345, #2929, #3742, #3746

If I get these and especialy the responses to them right, the additional code to limit a function which would otherwise just work as expected (i.e. offline editing with a configurable editor) is there, because the "edit" function is only implemented for "automatic transfer". But this in turn isn't automatic (and thus broken to quite some users) as has been reported and confirmed several times, e.g.: #1406, #2765, #2899, #2914, #2992

Furthermore altering "open" (and "double click on files") to make it an alternative to "edit" is refused because Filezilla shall not be a file management tool.

On top of that the non-automatic "automatic upload" meanwhile can be disabled as it's behaviour did irritate several users who instead decided not to make use of it at all. Thus we now have an "edit" function for something which doesn't (fully) work in practice and an "open" function which is useless to most of us.

But if Filezille must not be a file management tool then why is Filezilla insisting on displaying a listing of local files at all? It's even not possible to turn that off.

Either proper file management should be implemented/allowed, or the fractional (or should I say bugged?) file lisitng thingy should be removed completely. Because in the current form it is confusing at best an leads to data corruption or even data loss at worst. Additionally this step would release space on the screen (which could be used by a proper file management tool instead).

Or in short: Filezilla should concentrate on it's job: FTP. It should leave the task of file management to the programs which are good at this "e.g. Explorer, Konqueror, Nautilus or Finder" (codesquid in response to Ticket #2929).

(Filezilla V3.2.0)

Change History (5)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: invalid
Status: newclosed

This isn't a patch.

comment:2 in reply to:  1 Changed 10 years ago by Matthias Seifert

Replying to codesquid:

This isn't a patch.

Sorry for selecting the wrong "Type". Finding out that this isn't a patch surely wasn't too hard as this already is said in the first three words of my ticket.

As it's now on state "closed for not filling out the form correctly" should I submit it again? And which Type shall I select this time to make sure that it isn't ignored again? One could well bring forward the argument that this isn't a bug report either as the behaviour described isn't a bug but a feature.

It's definitely not a feature request either, as I don't ask for any additional feature but az best for the removal of a feature.

And I don't have the slightest idea what is meant be "Other" as this isn't even mentioned in Ticket Submission Guide.

And excuse me for being such a moron.

comment:3 Changed 10 years ago by Tim Kosse

Type: PatchFeature request

If I remember how to edit categories, I'll add a Rant one.

But if Filezille must not be a file management tool then why is Filezilla insisting on displaying a listing of local files at all? It's even not possible to turn that off.

So that you can browse your local files and select them for transfer. Also things like directory comparison.

comment:4 in reply to:  3 Changed 10 years ago by Matthias Seifert

Resolution: invalid
Status: closedreopened

Replying to codesquid:

If I remember how to edit categories, I'll add a Rant one.

I definitely would appreciate that. :)

Replying to codesquid:

But if Filezille must not be a file management tool then why is Filezilla insisting on displaying a listing of local files at all? It's even not possible to turn that off.

So that you can browse your local files and select them for transfer. Also things like directory comparison.

Well even for this it doesn't work (in my case) as Filezilla doesn't detect files which I "generate" (other than by Filezilla itself) while it is already displaying the directory. Of course pressing F5 does the trick (with Windows), but this isn't exactly comfortable. (Maybe this is a bug? At least Filezilla 2 definitely did know how to handle this correctly.)

On the other hand I'm probabaly not the ordinary user, because I do prefer two (or more) windows for tasks like this, i.e. the source directory in one window and the destination in another. By this I can easily open several source and destination directory views and move files around just as I like to. Futhermore it's OS idepentant, i.e. this is how I work with Windows, Ubuntu, Knoppix, MacOS, RISC OS or whatever. Not only to transfer files by FTP of course, but also for file copying and things like that.

On the other hand this also is especially handy if one has connected more than one display to the computer - so maybe it wouldn't just be to please me, but to please quite a number of other users, too. (Even for directory comparision or things like that, as I easily can run Filezilla twice.)

Because of that I definitely would prefer if Filezilla were able to just display the content of a directory on the server. No "local file list" and no "directory tree" at all (yes, the latter can be done already).

All together obviously results in a feature request: Allow me to switch off the "local site" pane, please.

And another feature request is directly connected to that: Let me chose whether a directory listing is showing "local site" or "remote site" content. Maybe by a simple mouse click on the word (in front of the address line) - or instead a drop down list, which may be less irritating.

There are two ways (to me) this could work:

Either one can freely select the type for each pane, i.e. one could even have two server directories displayed side by side (which could by handy in some cases) but may result in one or the other design problem within Filezilla.

Or it is just a shortcut to the configuration entry

Interface -> Swap local and remote panes

Which should be quite easy to implement.

Just to make it clear: This second feature request means that the first one is no longer "allow me to switch off the 'local site' pane", but now is "allow me to switch off one pane". :)

comment:5 Changed 10 years ago by goodbytes

codesquid, no need to be rude if people are asking something that they need and you disagree. I have more than 20 years of programming experience, therefore my opinion should count for something. Here's my angle:

To save resources, I like to open FileZilla and no file manager, then to edit the local files as much as I want, test them on my local server as long as I want, and then, IF/WHEN I am satisfied with the result, upload the edited files on a remote server.

I don't want to use another file manager because I already have one in the opened FTP program, and because editing exists in all other FTP programs that I have used, including versions of FileZilla before people like you started to make "philosophic improvements" by limiting some of the existing functionality and explaining that with "what this program IS and IS NOT", something that only the USERS can answer properly. It is actually an "abandon feature" for me, that's how important I feel it is for my style of work.

So, instead of acting as an "open source super-bureaucrat" and discouraging people who come here with good intentions, asking for their problem to be solved, think about these two options:

  1. Remove the unnecessary restriction and allow editing of local files, or
  1. Add a new option in Edit + Settings + File Editing, which could be a simple check box with a label: "Allow editing of local files" or something like that. Then the users, not you, will decide if they agree with your thinking.
Note: See TracTickets for help on using tickets.