Opened 10 years ago

Closed 7 years ago

Last modified 6 years ago

#5273 closed Bug report (duplicate)

Daylight Saving Time calculation broken

Reported by: Mike McAngus Owned by:
Priority: normal Component: FileZilla Client
Keywords: DST Daylight Saving Time Cc:
Component version: Operating system type: Windows
Operating system version: XP SP2

Description

In ticket #2026, the last comment states, "The next version of FileZilla 3 will be able to calculate the timezone of the server automatically."

I'm using Filezilla Client 3.2.8.1 on Windows XP SP2 to connect to Oracle Enterprise Linux 5.4 (RedHat Linux Kernel 2.6) servers.

I and the servers are located in the same timezone (in fact, in the same city).

Before the switch to Daylight Saving Time, the time displayed in Filezilla for new files matched the time displayed on my PC and the time displayed for the file when viewed directly on the server.

Since the time change last weekend, we have found that the time displayed by Filezilla is 1 hour later than the the PC time at the time of saving and with the last modification time as displayed when viewed directly on the server.

The server and the PC times still match.

Change History (4)

comment:1 Changed 9 years ago by Shawn Welch

Apparently, this is still an issue because I just had the EXACT thing happen to me today. I too operate in the same timezone of my server and I know for a fact that the dates are correct on both my development and live servers. I run NTP on both so I have clock accuracy on both and they both automatically adjusted themselves yesterday when we "spring"...sprung?...ahead. But today, I see that all files on the remote listing in FileZilla are 1 hour more than what 'ls -la' shows.

comment:2 Changed 9 years ago by Shawn Welch

oh...and:

FileZilla Client


Version: 3.3.5.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2010-11-21
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.11
GnuTLS: 2.10.2

Operating system:

Name: Windows XP (build 2600, Service Pack 2)
Version: 5.1
Platform: 32 bit system

comment:3 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #8171.

comment:4 Changed 7 years ago by Mike McAngus

This ticket opened 2 years a go is a duplicate for one opened 4 days ago?

What annoys me is that there is no reference from the new ticket back to this one, so the information provided by shrimpwagon and me is not readily available as part of the history of this issue.

This is now an 8 year old (at least) issue, from ticket 2026 to 4134 to 5237 to 8171.

Note: See TracTickets for help on using tickets.