Opened 6 years ago

Closed 6 years ago

#9814 closed Bug report (fixed)

freeze and shutdown when renaming local files

Reported by: hh Owned by:
Priority: high Component: FileZilla Client
Keywords: rename, local, linux, gnome Cc:
Component version: Operating system type: Linux
Operating system version: Linux my-pc 3.16.1-1-ARCH #1 SMP PREEMPT Thu Aug 14 07:40:19 CEST 2014 x86_64 GNU/Linux

Description

I click on a local file and then rightclick and 'rename'. Then I click into the filename and type a change. When I hit enter, filezilla does not do anything anymore. I can wait or force closing it.

When I restart it, the file is renamed.

Change History (4)

comment:1 Changed 6 years ago by hh

I tried to create a debug logfile but it was not created by these actions.

comment:2 Changed 6 years ago by Tim Kosse

Status: newmoreinfo

Which version of FileZilla are you using? Are you using the official binaries from https://filezilla-project.org/ or are you using a package from your distribution?

comment:3 Changed 6 years ago by hh

Status: moreinfonew

I am using the archlinux package from the repositories.

FileZilla Client
----------------

Version:          3.9.0.3

Build information:
  Compiled for:   x86_64-unknown-linux-gnu
  Compiled on:    x86_64-unknown-linux-gnu
  Build date:     2014-08-13
  Compiled with:  gcc (GCC) 4.9.1
  Compiler flags: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -Wall -g -fexceptions -std=gnu++11

Linked against:
  wxWidgets:      3.0.1
  GnuTLS:         3.3.7
  SQLite:         3.8.6

Operating system:
  Name:           Linux 3.16.1-1-ARCH x86_64
  Version:        3.16

I have also tried a nightly build (2014-08-31) yesterday, which had the same problem.

comment:4 Changed 6 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

This is caused by a bug in wxWidgets. You need to recompile wxWidgets with this patch applied: http://svn.wxwidgets.org/viewvc/wx?view=revision&revision=76808

Please contact your distribution's maintainer for the wx package so that it is included for all users of Arch Linux.

Note: See TracTickets for help on using tickets.