Opened 5 years ago

Closed 5 years ago

#9750 closed Bug report (duplicate)

Window Off Scree, can't resize or zoom to fix

Reported by: Gav Owned by:
Priority: normal Component: FileZilla Client
Keywords: option click/drag Cc: vjmcmahan@…
Component version: Operating system type: OS X
Operating system version: 10.9.4

Description

Filezilla window is off screen, top left. Can't see close/zoom red yellow green buttons or window header.

Probably related to me having two monitors (one 1920p main monitor, smaller MacPro laptop acting as second monitor).

Most apps have a Window menu with the zoom option so I can fix this, FileZilla doesn't. Tried closing and opening the app. Tried changing desktop res. No go.

Attachments (1)

Screen Shot 2014-08-07 at 21.41.51.png (200.6 KB) - added by Gav 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by Gav

comment:1 Changed 5 years ago by Janene McMahan

Cc: vjmcmahan@… added
Keywords: option click/drag added

Hi GavinT - I had this same problem this morning. Frustrated, I turned to the web. Window menu fixes (from 2010 and 2011 of clicking zoom... don't work because there is no window menu.)

However, on your mac you should be able to hold down the option key (alt) and click/hold with your mouse in the bottom right corner to drag and resize the menu. You'll note that the top of the window begins to move downward depending upon how you resize/move your mouse. Give it a try. It worked for me.

comment:2 Changed 5 years ago by Gav

I finally got the window back by first resizing it using the bottom right corner sizer and making it as small as it would go. Then changing the desktop res again.

Would be nice if FileZilla devs could detect on start if the window corners are out of screen bounds and simply change to default values though.

comment:3 Changed 5 years ago by Tim Kosse

Resolution: worksforme
Status: newclosed

You can hold Ctrl+Alt+Shift (or the Mac equivalent of that) when starting FileZilla to reset its window layout.

comment:4 Changed 5 years ago by Gav

Closed! So the normal user is meant to know to hold down some keys when this happens in FileZilla?

I'm pretty sure it is a bug that should be fixed in the app, a pretty simple fix too with a simple check for the window being created out of bounds.

comment:5 in reply to:  4 Changed 5 years ago by Janene McMahan

Replying to GavinT:

GavinT - Hi... I am just a 'normal' user - in no way affiliated with FileZilla, but since I figured out what to do, I thought I'd pass this info along to you (essentially because things like this derail me and bug me, and I was hoping to help out a fellow FZ user.)

However, The response from codesquid is super cool and something I'll try to remember if I run into a bug like this with other tools. Perhaps they'll include information in their help (I didn't check) or on their website (I didn't check) or check for the window out of bounds as you recommend in their next release, who knows. - Janene

Closed! So the normal user is meant to know to hold down some keys when this happens in FileZilla?

I'm pretty sure it is a bug that should be fixed in the app, a pretty simple fix too with a simple check for the window being created out of bounds.

comment:6 Changed 5 years ago by Gav

Resolution: worksforme
Status: closedreopened

OK Janene,

Sorry, I'm new to this forum.

I thought I'd reported this as a bug correctly, is this not the place to report bugs for the developers to see and fix? I wasn't asking for help as such.

If this is the place, then I think it would be wise not to close the bug report unless it is fixed. Or is that not how this bug list works, do closed issues still get seen by the developers?

I'm 100% sure this is bug that should be fixed BTW. I'm a 20+ year software developer myself and have seen this in own apps in the past, it is the sort of bug that needs fixing in code and not put in a help manual.

comment:7 Changed 5 years ago by Don Huff

+1

Obscure key combinations are not helpful. Ideally, add the standard Window menu. Another suggestion is putting an option in Preferences to clear the window layout.

Thanks,

-Don

comment:8 Changed 5 years ago by Alexander Schuch

Resolution: duplicate
Status: reopenedclosed

This is a duplicate of ticket:7175.

Note: See TracTickets for help on using tickets.