Opened 9 years ago

Closed 5 years ago

#7175 closed Bug report (worksforme)

Can't move Filezilla for Mac window. The top of Filezilla is stuck under the Mac menu bar.

Reported by: Steve Owned by:
Priority: high Component: FileZilla Client
Keywords: can't move filezilla window Cc: sam@…
Component version: Operating system type: OS X
Operating system version: OS X 10.9.4

Description

I have the latest version of Filezilla for Mac and am using Mac OS 10.5.8.

The problem is that the top of the Filezilla window is stuck under the Macs menu bar so I can't move the Filezilla window to a different location on my screen.

I took a screenshot of it but don't see anywhere here to attach it so you can see it.

Thanks

Attachments (1)

Filezilla stuck on Mac.tiff (90.2 KB) - added by Steve 9 years ago.
Screenshot of Filezilla for Mac stuck under Mac menu bar so Filezilla can't be moved on my screen.

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by Steve

Attachment: Filezilla stuck on Mac.tiff added

Screenshot of Filezilla for Mac stuck under Mac menu bar so Filezilla can't be moved on my screen.

comment:1 Changed 7 years ago by thunderw

May be there is something todo with this wxWidgets issue?
http://forums.wxwidgets.org/viewtopic.php?f=23&t=29589
Cannot move main App window by dragging Mac Toolbar

comment:2 Changed 7 years ago by whateva

I just had this problem on my macbook pro and have a temporary fix.

The temporary fix is to choose Window -> Zoom in the top menu bar. This will fit the Filezilla window fully on to the screen. You should now be able to move the Filezilla window using it's topbar. If not, then shrink it a little first. Hope this helps someone.

comment:3 Changed 5 years ago by Hélio

there is no Window -> Zoom option

comment:4 Changed 5 years ago by Sam

Cc: sam@… added
Operating system version: OS X 10.5.8OS X 10.9.4

I have this same problem. I'm still in need of a solution. Right now, my only option to get my immediate job done is to use another FTP client. (As heliob says, there IS NO Window -> Zoom option. Why would FileZilla not include this Mac OSX menu that every other app has?!) I updated to FileZilla 3.9.0.3 hoping it would help, but it does not.

comment:5 Changed 5 years ago by Sam

Here's a screenshot.https://www.evernote.com/shard/s85/sh/4b3593e2-a292-4cf1-bdb0-351d5ad2d1a6/d3291b0df9bb96cb3a958068a5b9fba5

comment:6 Changed 5 years ago by Hélio

that's because it probably is not a basic requirement of apple, if not think they would do right ...

comment:7 Changed 5 years ago by Sam

By luck I just discovered that if you hold down the Option key and then click on one of the borders of the window, you can drag the whole window down. Normally, when you click on the border you can only move that border in or out, not the whole window. Clicking Option before clicking on the border allowed me to drag the entire window down back into the screen. Whew!

The bug still needs fixing, though.

comment:8 Changed 5 years ago by anatolia

The setting information is in:

/Users/yourhome/.filezilla

By erasing all files in this directly, the filezilla window came back to the center of the display.

The bookmarks and connection data will also be erased. Be prepare for that.

comment:9 Changed 5 years ago by Hélio

just erase /Users/youruser/.config/filezilla/filezilla.xml to not lost sitemanager.xml

but the bug remains, and the staff of filezilla nothing ...

comment:10 Changed 5 years ago by Alexander Schuch

"You can hold Ctrl+Alt+Shift (or the Mac equivalent of that) when starting FileZilla to reset its window layout." -- Taken comment:3:ticket:9750.

comment:11 Changed 5 years ago by gwhiz

For MAC the key commands to reset FZ are SHIFT OPTION COMMAND. Hold them down, then click on the FZ icon in the doc or in the Applications folder.

THe other solution mentioned above, holding down the OPTION key might work too depending on how far the window is offscreen. You have to grab FZ's lower corner (right or left is OK) while holding down OPTION, then drag the corner of the window UP. This will raise up the lower edge of the window and BRING DOWN the TOP of the window simultaneously.

I didn't get the effect that holding down OPTION allows dragging the whole window but that would certainly be great.

comment:12 in reply to:  11 Changed 5 years ago by PSR

Replying to gwhiz:

For MAC the key commands to reset FZ are SHIFT OPTION COMMAND. Hold them down, then click on the FZ icon in the doc or in the Applications folder.

THe other solution mentioned above, holding down the OPTION key might work too depending on how far the window is offscreen. You have to grab FZ's lower corner (right or left is OK) while holding down OPTION, then drag the corner of the window UP. This will raise up the lower edge of the window and BRING DOWN the TOP of the window simultaneously.

I didn't get the effect that holding down OPTION allows dragging the whole window but that would certainly be great.

Great thanks, solved it! Used the option key --> made window smaller so top bar would be visible and then was able to drag over the screen, resize etc...

comment:13 Changed 5 years ago by CJ

Thanx for the hints on where the settings are stored.

I got the window unstuck on my Mac by

1) Shutting down Filezilla
2) Editing /Users/username/.filezilla/filezilla.xml

Searching for this line:

Original: <Setting name="Window position and size">0 0 -56 1504 1126 </Setting>

Changing it to:

New: <Setting name="Window position and size">10 10 -56 1504 1126 </Setting>

3) When I opened it back up, it's fixed. :)

comment:14 Changed 5 years ago by Raül Rodríguez

Resolution: worksforme
Status: newclosed

The last answer worked for me like a charm :) So I would suggest set up that config by default in the xml file. (next version).

Thank you! :D

Note: See TracTickets for help on using tickets.