Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#9667 closed Bug report (fixed)

Multiple simultaneous downloads on OS X locks up UI and slows downloads significantly

Reported by: zeeropointzeero Owned by: Tim Kosse
Priority: normal Component: FileZilla Client
Keywords: multiple simultaneous transfers downloads speed slow UI locks locked Cc:
Component version: Operating system type: OS X
Operating system version: 10.9.4

Description

When transferring a large batch of files on 3.9.0 (hundreds of files averaging between 2KB and 300KB), 10 simultaneous transfers at once, the UI locks up (although the app is still downloading and the command echo window is still scrolling through commands). The downloading slows to approximately 5-10% of available network speed (and I can see the echo window slows commands to this rate as well). Once all files have been downloaded, the UI becomes accessible again.

Note, I had no problems performing the same actions above on 3.8.1. On that older version, downloads were at full speed and the UI never locked up.

I confirmed that this is a new issue introduced since v3.8.1. I recreated the issue on 3.9.0, then I downgraded from 3.9.0 back to 3.8.1 and the issue went away (speeds went back to normal and UI was accessible during this download process). So that rules out an issue with my computer, OS, network or server.

I have not tested if this affects multiple simultaneous uploads as well.

Change History (3)

comment:1 Changed 6 years ago by Tim Kosse

Owner: set to Tim Kosse
Status: newaccepted

This issue also affects 3.8.1 and older on very fast connections, especially if using FTP over TLS.

Hiding the message log, e.g. via the toolbar button, should increase performance a bit.

Work is under way to fundamentally change the architecture of FileZilla to solve this problem.

comment:2 Changed 5 years ago by Tim Kosse

Resolution: fixed
Status: acceptedclosed

If you are feeling adventurous, you can have an early look at the upcoming changes in the latest nightly build: https://filezilla-project.org/nightly.php

comment:3 Changed 5 years ago by Tim Kosse

The main reason for this slowdown is that Apple is intentionally deprecating and removing vital APIs in order to promote their latest over-hyped fad. For optimal performance you might want to use a different operating system. Fast GUI applications written in C++ are becoming increasingly more difficult on OS X.

Note: See TracTickets for help on using tickets.