Opened 6 years ago

Closed 6 years ago

#8678 closed Feature request (duplicate)

Updates behind http proxy sever

Reported by: David Clayton Owned by:
Priority: low Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: 7 X64

Description

Hi,

I have several installations of FZ Client on the network, The update module is able to retrieve the latest version, clicking next prompts the 'save file' dialogue', it then attempts to contact a number of severs over port 80:

Status: Downloading /updatecheck.php?platform=i586-pc-mingw32msvc&version=3.5.3&osversion=6.1&osarch=32
Status: Resolving address of update.filezilla-project.org
Status: Connecting to 62.75.138.232:443...
Status: Connection established, initializing TLS...
Status: Verifying certificate...
Status: TLS/SSL connection established, sending HTTP request
Command: GET https://update.filezilla-project.org/updatecheck.php?platform=i586-pc-mingw32msvc&version=3.5.3&osversion=6.1&osarch=32 HTTP/1.1
Response: HTTP/1.1 200 OK
Response: Date: Thu, 09 May 2013 11:10:11 GMT
Response: Server: Apache/2.2.3 (Debian) PHP/5.2.0-8+etch16 mod_ssl/2.2.3 OpenSSL/0.9.8c
Response: X-Powered-By: PHP/5.2.0-8+etch16
Response: Content-Length: 2276
Response: Connection: close
Response: Content-Type: text/plain; charset=UTF-8
Status: Disconnected from server
Status: File transfer successful, transferred 2.23 KB in 1 second
Status: Disconnected from server
Status: Downloading /filezilla/FileZilla_3.6.0.2_win32-setup.exe
Status: Resolving address of downloads.sourceforge.net
Status: Connecting to 216.34.181.59:80...
Status: Connection attempt failed with "ETIMEDOUT - Connection attempt timed out".
Error: Disconnected from server: ETIMEDOUT - Connection attempt timed out

I assume this is because it is not going via the network's web proxy?

Could it download a new version using FTP?

David

Change History (2)

comment:1 Changed 6 years ago by Steltek

I would prefer it if the Client used the same protocol to do the downloading than what it uses to do the checking.

i.e.: You're doing the check via HTTPS, so if that works, it should be safe to assume that the download also works via HTTPS.

This isn't the case right now, so while the Client tells me that there's a new update available, it can't download it, as it tries to do the download via HTTP, which requires authentication behind our proxy.

comment:2 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #4508.

I added your last comment there already. Feel free to add more information there, if not already present.

Note: See TracTickets for help on using tickets.