Opened 7 years ago

Closed 6 years ago

Last modified 4 years ago

#8211 closed Bug report (invalid)

Right clicking on directory/file name while renaming freezes/crashes FileZilla

Reported by: cbichis Owned by:
Priority: high Component: FileZilla Client
Keywords: Version 3.7.1 Cc: cbichis
Component version: Operating system type: Linux
Operating system version: Ubuntu 13.10

Description (last modified by Alexander Schuch)

Hi,

When trying to rename / click a remote folder (maybe a file too not sure) the Local Directory tree is freezing (I can't go to subfolders or to upper folder; not sure about scrolling if works right now I have a tiny directory list) and I can't show the right click menu and the Remote Folder tree is scrollable but I can't navigate through folders neither right click menu does not appear.

The main menu seems to work.

The file transfers are working ok meantime if something in queue. To fix the issue I need to kill/close FileZilla and start again.

This is happening very often.

Change History (19)

comment:1 Changed 7 years ago by cbichis

I forgot to mention Filezilla becomes unkillable from titlebar, and I need to killall to kill it...

FileZilla version is 3.5.3

comment:2 Changed 7 years ago by Alexander Schuch

Status: newmoreinfo

Just to make sure, you do the following?

1) click on a non-selected remote[!] directory once
2) click on the selected remote[!] directory again
3) the inline rename opens
4) local[!] directory tree is frozen

At point 3, can you type new text for the directory name?

And, do you use any special character encodings? Or simply plain ASCII?

comment:3 Changed 7 years ago by trurl-master

Status: moreinfonew

I'm not sure it exactly the same issue but simptoms are similar.

This one is freezes filezilla 3.5.3:
1) Click on a non-selected local/remote file/directory once
2) Click on a selected local/remote file/directory again
3) The inline rename opens
4) Right click on inline rename field
5) Inline field closes and filezilla is freezed

Not only in tree view.

comment:4 Changed 7 years ago by cbichis

Btw, I noticed myself there is similar issue with local folders as well (not just with remote), in mentioned circumstances the freeze occurs as well.

comment:5 Changed 7 years ago by cbichis

I just reproduced the issue:

  1. I click on a file and it opens the editing box
  2. Then i righ click on editing box
  3. Freeze occurs

comment:6 Changed 7 years ago by cbichis

Cc: cbichis added

comment:7 Changed 7 years ago by Alexander Schuch

I am not able to reproduce this problem exactly. But I played around a bit and I can crash FileZilla using the following:

  • I connect to an FTP server.
  • I click on a non-selected remote item.
  • I click on the selected remote item again.
  • The inline edit starts.
  • I clear the field so that it is empty.

a) I click on another item. FileZilla now shows a dialogue "Filename invalid". And it then freezes. But it does not always happen.

b) I right-click on the empty field. FileZilla now shows a dialogue "Filename invalid". After pushing the "OK" button, FileZilla does a segmentation fault.

None of the steps above work locally - they only work remotely.

comment:8 Changed 7 years ago by cbichis

ci-dev, the issue is so annoying and frequent that I started to look for an alternative to Filezilla...

comment:9 Changed 7 years ago by Alexander Schuch

Priority: normalhigh

comment:10 Changed 7 years ago by Raül Rodríguez

Operating system version: Ubuntu 12.04Ubuntu 12.04 LTS

Hi,

To reproduce the bug, as commented before:

  1. Click twice on any remote file to open the editing box (rename)
  2. Then right click with mouse on editing box
  3. Freeze occurs

Version: 3.5.3

comment:11 Changed 7 years ago by Alexander Schuch

Summary: Directory trees freezeRight clicking on directory/file name while renaming freezes/crashes FileZilla

This happens as well in Ubuntu 12.04 LTS and with FileZilla 3.7.0.1, see #8479 as reference.

comment:12 Changed 6 years ago by Alexander Schuch

I can confirm that the bug still persists on ubuntu 13.04, 64-bit. It is obviously related to Gtk. It is easily reproducable within a mere 2 seconds:

  1. double click a file in Filezillas file explorer so to rename it
  2. right click on the input text field for renaming the file while it isn't closed yet
  3. Filezilla freezes (i.e. refuses to respond to any input at all, instead producing error messages).

Here the two types of error messages Filezilla spams onto my console while I move my cursor across it:

(filezilla:6785): Gtk-CRITICAL **: IA__gtk_widget_is_sensitive: assertion `GTK_IS_WIDGET (widget)' failed
(filezilla:6785): Gtk-CRITICAL **: IA__gtk_propagate_event: assertion `GTK_IS_WIDGET (widget)' failed

I use the default Ubuntu 13.04, 64-bit (Gnome 3.6), and tested it again with the latest build "FileZilla 3.7.1 official build, compiled on 2013-06-18"

This Bug is particularly annoying to me, and I'll donate 15 € as soon as I have a Filezilla version wherein it is fixed.

-- Quimoniz in #7381

comment:13 Changed 6 years ago by Raül Rodríguez

Keywords: Version 3.7.1 added
Operating system version: Ubuntu 12.04 LTSUbuntu 13.10

I can confirm that the bug still persists on ubuntu 13.10 32-bit and 64-bit, Filezilla 3.7.1. It is obviously related to Gtk. It is easily reproducable within a mere 2 seconds:

  1. double click a file in Filezillas file explorer so to rename it
  2. right click on the input text field for renaming the file while it isn't closed yet
  3. Filezilla freezes (i.e. refuses to respond to any input at all, instead producing error messages).

Here the two types of error messages Filezilla spams onto my console while I move my cursor across it:

(filezilla:6785): Gtk-CRITICAL : IAgtk_widget_is_sensitive: assertion `GTK_IS_WIDGET (widget)' failed
(filezilla:6785): Gtk-CRITICAL
: IAgtk_propagate_event: assertion `GTK_IS_WIDGET (widget)' failed

I use the default Ubuntu 13.10, 32-bit and 64-bit(Gnome 3.6), and tested it again with the latest build "FileZilla 3.7.1 official build, compiled on 2013-06-18"

comment:14 Changed 6 years ago by Zac DavidM

I am confirming this bug and adding more info.
Ubuntu 12.04 LTS and Filezilla 3.5.3 .

After reproducing the steps above (opening filezilla from terminal) I get two error messages.

While mouse is in any single visual panel:
(filezilla:4403): Gtk-CRITICAL : IAgtk_propagate_event: assertion `GTK_IS_WIDGET (widget)' failed

When mouse crosses to a different panel:
(filezilla:4403): Gtk-CRITICAL : IAgtk_widget_is_sensitive: assertion `GTK_IS_WIDGET (widget)' failed

After the mouse has crossed into the new panel, error 1 again continues to print to console.

Does anyone have a fix, or a version that this does not happen in? This problem has become aggravating as I have to killall filezilla many times throughout the day and reconnect.

comment:15 Changed 6 years ago by Alexander Schuch

Taken from #9228:

Slow double click to rename file then right click freezes whole interface.

This happens to me farely often, I will click a file slowly twice usually by accident, and then right click (my initial intended action). If you right click in that text box that appears after the slow double click it freezes everything. I can still Exit through global menu but that is about it.

I am using Ubuntu 13.10 and filezilla 3.7.3 I have had this issue for a long time over several versions of each.

And one more detail:

Does it also freeze if you start the editing by using the F2 key instead of the two single-clicks? -- Yes it also freezes if I hit F2 instead.

comment:16 Changed 6 years ago by pappacurds

Resolution: invalid
Status: newclosed

This problem is a result of a compatibility issue between wxWidgets and Gtk. This problem is therefore not a FileZilla bug but instead a bug in the GUI software it uses.

comment:17 in reply to:  16 Changed 5 years ago by Alexander Schuch

Replying to pappacurds:

This problem is a result of a compatibility issue between wxWidgets and Gtk. This problem is therefore not a FileZilla bug but instead a bug in the GUI software it uses.

codesquid contributed many many patches to wxWidgets already. So I see at least a very small chance that this bug could be fixed. Anyway, is upstream aware of that problem? Can you please link to a bug report in wxWidgets? After all, we all are FOSS.

comment:18 Changed 5 years ago by Jabba

So I see at least a very small chance that this bug could be fixed.

Just wanted to report that unfortunately, this is still happening in 3.9.0.1.

comment:19 Changed 4 years ago by Alexander Schuch

Description: modified (diff)

You should check with FileZilla 3.13.0, wxWidgets 3.0.2 and whatever is the most recent version of GTK. Still, this very likely is an upstream problem. Maybe it is known by upstream already, maybe not. I do not know.

I just hope that pappacurds reported this issue somewhere upstream and simply forgot to link back here.

Note: See TracTickets for help on using tickets.