Opened 6 years ago

Closed 6 years ago

#8479 closed Bug report (duplicate)

Right clicking on folder/file name while renaming freezes FileZilla

Reported by: Vishnu Nampoothiry Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc: vishnu@…
Component version: Operating system type: Linux
Operating system version: Ubuntu 12.04.2 LTS

Description

In both local and remote file explorers, while renaming a file/folder, if I right click on it, the text box (of renaming) turns into folder/file name and FileZilla freezes. While freezed, main menu items can be used without any problem but icons, log window, file explorers, queue, etc does not respond to my clicks neither can I close by clicking on close button on title bar (but File > Exit works).

I enabled verbose but nothing appears in the log when I right click.

This latest version of FileZilla was downloaded from FileZilla website and earlier version which I had was installed via Synaptic Package Manager and that too had the same problem.

On my system it can be easily recreated. I have to just:
Start FileZilla > in local explorer (tree or list) right click, rename > in the text box for renaming, right click > application freezed.


FileZilla Client
Version: 3.6.0.2

Build information:

Compiled for: i586-pc-linux-gnu
Compiled on: x86_64-unknown-linux-gnu
Build date: 2012-11-29
Compiled with: gcc (Debian 4.4.5-8) 4.4.5
Compiler flags: -g -O2 -Wall -g -fexceptions -std=gnu++0x

Linked against:

wxWidgets: 2.8.12
GnuTLS: 3.1.4
SQLite: 3.7.9

Operating system:

Name: Linux 3.2.0-37-generic-pae i686
Version: 3.2

Change History (3)

comment:1 Changed 6 years ago by Vishnu Nampoothiry

Cc: vishnu@… added

comment:2 Changed 6 years ago by SomeLuigi

Priority: normalhigh

This also happens in 3.7.0.1.

This is a very painful bug because it's easy to do on accident by clicking the name of something, it opens up the rename box and you right click for the menu but instead it crashes.

comment:3 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #8211.

Note: See TracTickets for help on using tickets.