Opened 8 years ago

Closed 5 years ago

#7990 closed Feature request (duplicate)

timed bandwidth throttle mechanism (speed limit)

Reported by: moug Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type:
Operating system version:

Description

With limited bandwidth being shared Filezilla can be a bit of a data hog.

Can I suggest a kb/sec download limit maximum transfer rate. This is a similar mechanism that some bit torrent clients have (Vuze)

I would also imagine an improvement over this feature that would allow a timetable of transfer rates. This would for example allow an increase in transfer rates after office hours, or overnight when the network is idle.

An example would be below:

Start  End  Download Bandwidth    Upload Bandwidth
0830 - 1730 10k bytes per sec     5k bytes per sec
1731 - 2000 50k bytes per sec     20k bytes per sec
2001 - 0700 unlimited             unlimited
0701 - 0829 50k bytes per sec     20k bytes per sec

I think this would a very good feature in shared network environments and for unattended operation of backups/large complex transfers.

I would suggest having separate upload and download limits for people with asymmetrical bandwidth connectivity.

Change History (2)

comment:1 Changed 7 years ago by Alexander Schuch

Summary: A bandwidth throttle mechanismtimed bandwidth throttle mechanism (speed limit)

FileZilla already offers so called "speed limits" ("transfer" -> "Speed limits").

So this featur request is about timed speed limits then.

comment:2 Changed 5 years ago by Alexander Schuch

Resolution: duplicate
Status: newclosed

This is a duplicate of #4126.

Note: See TracTickets for help on using tickets.