Opened 9 years ago

Closed 3 years ago

#7856 closed Bug report (worksforme)

SFTP login failed with special character in password

Reported by: Derek Owned by:
Priority: normal Component: FileZilla Client
Keywords: SFTP password special character Cc: mikie
Component version: Operating system type: Windows
Operating system version: 7

Description

We had created a new SFTP username and password for one of our servers and although the login was tested and worked with WinSCP, it returned an authentication failure using FileZilla.

The password's last character was a pound sign (£) and on the suspicion that it might be causing a problem, we removed that last character. The login then worked correctly on both WinSCP and FileZilla.

I've looked around the FileZilla wiki but can't find mention of non-alphanumeric characters in passwords with are likely to cause problems. Any information would be appreciated.

Change History (4)

comment:1 by Tim Kosse, 9 years ago

Resolution: worksforme
Status: newclosed

The pound sign is not an ASCII character and thus its binary representation depends on the used encoding.

FileZilla uses UTF-8 as encoding, the de-facto standard. Unfortunately, older products or low-quality products still use localized character sets.

Please make sure to configure the server to fully support UTF-8 and set the password using UTF-8 enabled tools. If that is not possiblem you have to restrict yourself to ASCII characters.

comment:2 by mikie, 9 years ago

Cc: mikie added
Resolution: worksforme
Status: closedreopened

Hi there
Server environment used was a fully patched RedHat Enterprise Linux 5.7
password was set using linux utility passwd
ssh server was OpenSSH 5.9-P1
default settings (other than using the chroot capabilities with internal sftp in OpenSSH) were used throughout

all other products successfully login using the £ character in the password yet filezilla failed.

May i suggest that if industry standard (de-facto) software needs its defaults changed to make filezilla work then something is wrong with filezilla. Unless you feel that the OpenSSH devs are doing it wrong.

comment:3 by Alexander Schuch, 7 years ago

Status: reopenedmoreinfo_reopened

This has already been reported in #1370 and in #3125. And in both cases, as well as here, the answer always is the same: use UTF-8 everywhere.

FileZilla uses psftp, so if in doubt, please try that program directly:
http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html.

Do you still have that problem?

comment:4 by Kurt McKee, 3 years ago

Resolution: worksforme
Status: moreinfo_reopenedclosed
Note: See TracTickets for help on using tickets.