Opened 13 years ago

Last modified 6 years ago

#3125 closed Bug report

Login Failure if password contains a § (other special chars)

Reported by: bootsy52 Owned by:
Priority: normal Component: Other
Keywords: Cc: bootsy52, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

It is not possible to transfer Files using
SFTP over SSH if the Password contains a § sign.

This works in FileZilla 2.2.31.

FileZilla 3.0beta6 successfully authenticates and shows the diretory listing, however as soon as you want to actually transfer files, this fails with the error message "login failed".

Tested on Windows XP SP2 other Platforms maybe affected, too

Change History (5)

comment:1 Changed 13 years ago by Tim Kosse

Please download and try the most recent nightly build from http://filezilla-project.org/nightly.php.

If the nightly still fails, please attach some logs (using the nightly) showing the problematic behaviour.

State in your reply the date of the nightly build.

The logs should be made using debug level 3 which can be enabled
on the debug page in the settings dialog of FileZilla.

The logs have to be complete and unmodified. Do not attempt to
remove or obfuscate any information you might find irrelevant.

If you are worried about posting IP addresses or other
confidential information, mark the tracker item as private.

comment:2 Changed 12 years ago by bootsy52

Tested with Nigtly Build 2007-03-26 and Debug Level 3
this time under Linux. Error still present

Debug Log (changed, hostadress and SSH2 Fingerprint)

Status: Connecting to site.com:22...
Response: fzSftp started
Trace: CSftpControlSocket::ConnectParseResponse(fzSftp started)
Command: open username@… 22
Trace: Server version: SSH-2.0-OpenSSH_4.2p1 Debian-7ubuntu3.1
Trace: We claim version: SSH-2.0-PuTTY_Local:_Mar_26_2007_04:30:02
Trace: Using SSH protocol version 2
Trace: Doing Diffie-Hellman group exchange
Trace: Doing Diffie-Hellman key exchange with hash SHA-1
Trace: Host key fingerprint is:
Trace: ssh-rsa 2048
Trace: Initialised AES-256 SDCTR client->server encryption
Trace: Initialised HMAC-SHA1 client->server MAC algorithm
Trace: Initialised AES-256 SDCTR server->client encryption
Trace: Initialised HMAC-SHA1 server->client MAC algorithm
Trace: Pageant is running. Requesting keys.
Trace: Pageant has 0 SSH-2 keys
Command: Pass:
*
Trace: Sent password
Trace: Access denied
Error: Authentication failed.
Trace: CSftpControlSocket::ResetOperation(70)
Trace: CControlSocket::ResetOperation(70)
Error: Critical error
Error: Could not connect to server

comment:3 Changed 12 years ago by Tim Kosse

Not a problem with FileZilla.

Passwords are expected to be exchanged in UTF-8 with the server, exactly what most recent FZ3 nightly does.
This leaves two possibilities:

  • Server cannot handle UTF-8. Used SSH server version is rather old (OpenSSH 4.6 is current), an upgrade might be worthwile. Other tools like passwd or the used authentication libraries migh not UTF-8 capable either
  • The client/tool you used to set the password with was not UTF-8 capable and sent the data in a different encoding. It looks like a § on your system, but for the server it is something completely different.

comment:4 Changed 12 years ago by bootsy52

Can you probably just do me a favor and try to use a password containing a paragraph on your system? As I don't have problems to log in to this machine with putty, however psftp fails, too. I tried different systems now, but all with same result. Some have ISO-8859-15 set and other UTF-8 as system locale, but on all it does not work for me.

comment:5 Changed 12 years ago by Tim Kosse

Yes, works perfectly.

Your server might not support UTF-8 or the password is stored in some other encoding and the server performs no conversion.

Note: See TracTickets for help on using tickets.