Opened 9 years ago

Closed 4 years ago

#7203 closed Patch (rejected)

automatically trimming file name for downloading

Reported by: aukfilezilla Owned by: hamza
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Linux
Operating system version: Ubuntu 10.10

Description (last modified by Alexander Schuch)

fileZilla can not transfer file which name has space in the beginning. In downloading scenario, fileZilla will trim the file name first, then request it from server. Server will simply return 550 Failed to open file(in my case is vsftpd).

I can download the same file with space in the beginning of the file name using ftp(0.17-23). the fileZilla version is 3.3.5.1, build date is 2010-12-11

Please note not all files which name contains space in the beginning fail to download. For example, .swf file can be downloaded. but .txt, .jpg, .png file will reproduce the error

Attachments (1)

7203.patch (483 bytes) - added by Tautvydas Andrikys 7 years ago.
Fix for unix based servers

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by harsh

I am interested in working on this bug. How do i get this ticket assigned.
Harsh

Changed 7 years ago by Tautvydas Andrikys

Attachment: 7203.patch added

Fix for unix based servers

comment:2 Changed 4 years ago by hamza

Owner: set to hamza
Status: newassigned

comment:3 Changed 4 years ago by Alexander Schuch

Description: modified (diff)
Priority: criticalnormal
Type: Bug reportPatch

comment:4 Changed 4 years ago by Alexander Schuch

No idea about the patch, but without this patch, it definitely is a duplicate of ticket:8717.

comment:5 Changed 4 years ago by Tim Kosse

Resolution: rejected
Status: assignedclosed

In Unix-style directory listings, whitespace is used for padding.

If you have files containing leading or trailing whitespace you MUST use an MLSD capable server.

Note: See TracTickets for help on using tickets.