Opened 6 years ago

Closed 6 years ago

#8717 closed Bug report (wontfix)

Space as first character in file name

Reported by: Greg Waugh Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

Filezilla does not seem to be able to handle a file on a remote FTP site that starts with a space as the first character. It displays the file in the listing with the space trimmed off, however any operations (download, delete, rename) fail due to it sending the command with the trimmed version of the filename.

Change History (1)

comment:1 Changed 6 years ago by Alexander Schuch

Resolution: wontfix
Status: newclosed

The FAQ https://wiki.filezilla-project.org/Limitations explains:

FileZilla ignores leading space of filename or directory

This happens on FTP servers not supporting the MLSD command. On those servers FileZilla falls back to LIST. Unfortunately the listing format returned by LIST is not standardised. It is impossible to distinguish leading spaces from padding. To solve this issue, simply upgrade to a modern server supporting the MLSD command or refrain from using leading spaces.

If it happens with MLSD, please re-open this issue. Thank you.

And by the way, this also is a duplicate of #5210.

Note: See TracTickets for help on using tickets.