Opened 9 years ago

Closed 5 years ago

#7174 closed Bug report (rejected)

File changing by upload (from Linux ftp client)

Reported by: Eugene Owned by:
Priority: high Component: FileZilla Server
Keywords: upload problem Cc:
Component version: Operating system type: Linux
Operating system version:

Description

I have

  1. FileZilla-server on windows XP
  2. default linux ftp-client (ftp) on Ubuntu 9.10
  3. Some text files and zip-archives on Ubuntu-computer (for examlple "data.txt" is text file)

To look the problem:
on Ubuntu-computer

$ ls -l data.txt

-rw-r--r-- 1 root root 274981544 2010-09-27 12:34 data.txt

$ ftp 192.168.3.20

Connected to 192.168.3.20.
220-FileZilla Server version 0.9.37 beta
220-written by Tim Kosse (Tim.Kosse@…)
220 Please visit http://sourceforge.net/projects/filezilla/
Name (192.168.3.20:user): anonymous
Password:
230 Logged on
Remote system type is UNIX.

ftp> put data.txt

local: data.txt remote: data.txt
200 Port command successful
150 Opening data channel for file transfer.
226 Transfer OK
275173412 bytes sent in 24.86 secs (10809.4 kB/s)

275173412! not 274981544.
if we download this file from ftp-server back and compare with original by "diff", we'll see non-printed char

^M

on the end of each line.

I've tried to copy files on Xlight FTP-server (on Windows) and proftp-server (on Linux) - it was ok (size of file and its content was not changed). Copy by smb-protocol is ok too;

General problem is uploading zip-archives. They often become damaged and can't be unzip.

Upload from Windows to Windows has no problem.

Change History (1)

comment:1 Changed 5 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is by design. FTP performs line-ending conversion for text files. See https://wiki.filezilla-project.org/Data_Type

Note: See TracTickets for help on using tickets.