Opened 9 years ago

Last modified 6 years ago

#7173 new Bug report

Can't add bookmarks for MVS paths

Reported by: Andrew Schulman Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Other
Operating system version:

Description

When I connect to an MVS host and try to add a bookmark to e.g. 'A036.FILES.XREF', I always get a popup dialog that says:

Could not parse remote path.

I get the same result with or without the enclosing quotes around the path.

FileZilla Client


Version: 3.3.5.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2010-11-21
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.11
GnuTLS: 2.10.2

Operating system:

Name: Windows XP (build 2600, Service Pack 3)
Version: 5.1
Platform: 32 bit system

Change History (8)

comment:1 Changed 7 years ago by Stavros

I would like to join the effort of fixing this bug.
The MVS platform seems to be spread widely across the industry and a lot of people are having this annoying popup dialog preventing them from adding a bookmark, which on MVS platforms is essential since the folders do not really have meaningful names.
At least in my department (40 people @ Stuttgart, Germany).

So if anybody can fix this, please give it a try. I am willing to assist in testing.

The popup is shown in line 69 of \src\interface\bookmarks_dialog.cpp

comment:2 Changed 7 years ago by Stavros

I FOUND A WORKAROUND!!!!!!!!!!!!!

Obviously the popup is shown because CServerPath::SetPath() with a MVS path like 'abc.def.ghi.' in line 101 in \engine\serverpath.cpp returns false.
In line 124 the m_type is only set to MVS if the first and last char of the path is a
FTP_MVS_DOUBLE_QUOTE which is a constant with the value of 220, being the german letter Ü.

So if you just add a Ü as the first and last char in the bookmark dialog box,e.g.

Ü'abc.def.ghi.'Ü

then it works!!!

comment:3 Changed 7 years ago by Stavros

Is there a speific reason why this constant is set to 0xDC (220 decimal)?

comment:4 Changed 7 years ago by Tim Kosse

Status: newmoreinfo

Which kind of bookmark are you trying to add? A global or a site-specific one?

comment:5 Changed 7 years ago by Stavros

Status: moreinfonew

actually, a global one.
I just tried to add a site-specific one and it worked.

ooops! So that was the mistake all the time?
(But why is it parsed differently?)

comment:6 Changed 7 years ago by Andrew Schulman

I just tried again, and both the global and site-specific bookmarks fail. I get the same result with any of the following remote paths:

CEPAPQK.FILES.SDWRPT
'CEPAPQK.FILES.SDWRPT'
"CEPAPQK.FILES.SDWRPT"

comment:7 in reply to:  6 ; Changed 7 years ago by Stavros

try to add a period at the end

'CEPAPQK.FILES.SDWRPT.'

comment:8 in reply to:  7 Changed 7 years ago by Andrew Schulman

Replying to zissakos:

try to add a period at the end

'CEPAPQK.FILES.SDWRPT.'

No, same result I'm afraid.

But, I can confirm what you found in comment:2: I can bookmark

Ü'CEPAPQK.FILES.SDWRPT'Ü

Filezilla accepts this, and then the bookmark does the right thing when I go to it.

Note: See TracTickets for help on using tickets.