Opened 16 years ago

Last modified 6 years ago

#611 closed Bug report

VMS connection doesn't work

Reported by: njall Owned by:
Priority: normal Component: Other
Keywords: Cc: njall, Tim Kosse, juergenf
Component version: Operating system type:
Operating system version:

Description

Connected successfully to a VMS system running VMS 7.2
and UCX 5.3 I see no directory listing. The "Dump
Directory Cache" file looks like this:


FileZilla Directory Cache Dump

Dumping 1 cached directories

Entry 1:
Path: DISK$CAM:[NINGERSOLL]
Server: ningersoll@…:21, type: 256
Directory contains 0 items:


This is my root directory and there are a lot of files
and directories. An "ls" from Windows FTP shows lots
of files. Occassionally I see garbled VMS directory
info. The debug file I have attached shows another
version of the "Directory Cache".

Attachments (1)

Directory Cache Dump.txt (7.6 KB) - added by njall 16 years ago.
Debug session log

Download all attachments as: .zip

Change History (5)

Changed 16 years ago by njall

Attachment: Directory Cache Dump.txt added

Debug session log

comment:1 Changed 16 years ago by Tim Kosse

Hi, try to disable "Show hidden files", the server doesn't
seem to support this. If FileZilla still fails to display
the directory contents, please send me another message log
(the cache contents are of no use in this case)

comment:2 Changed 16 years ago by njall

Yes indeed, disabling "Show Hidden Files" corrects the
problem. Thank you! The filetype field isn't quite right.

Apparently the VMS method of "backups", i.e. file versions,

is confusing the code. I will submit that as a seperate
issue.

comment:3 Changed 15 years ago by juergenf

On my VMS-System that workaround doesn't work.

Log shows the following:


Response: 226 LIST Directory transfer complete.
Trace: Directory U$USLTS1:[DAT.SAP]
Trace: DIR_SAP_IN.COM;21 3/3 9-APR-
2003 [USL_TS1] (RWED,RWED,RWED,RE)
Trace: FIJ.COM;7 1/3 3-DEC-2002
[USL_TS1] (RWED,RWED,RWED,RE)
Trace: FTP_PREPARE.COM;43 7/9 3-DEC-
2002 [DCCSAPFT] (RWED,RWED,RWED,RE)
Trace: FTP_UNIX.COM;91 9/9 19-DEC-2002
[DCCSAPFT] (RWED,RWED,RWED,RE)
Trace: IN.DIR;1 2/9 20-NOV-2002 [DCCSAPFT]
(RWE,RWE,RWE,RE)
Trace: OUT.DIR;1 1/3 20-NOV-2002
[DCCSAPFT] (RWE,RWE,RWE,RE)
Trace: UCX$FTPSERVER.LOG;218 1/6 24-JUN-
2004 [DCCSAPFT] (RWED,RWED,RWED,RE)
Trace: UCX$FTPSERVER.LOG;217 1/6 24-JUN-
2004 [DCCSAPFT] (RWED,RWED,RWED,RE)
Trace: UCX$FTPSERVER.LOG;216 1/3 24-JUN-
2004 [DCCSAPFT] (RWED,RWED,RWED,RE)
Trace: UCX$FTPSERVER.LOG;215 1/3 13-APR-
2004 [DCCSAPFT] (RWED,RWED,RWED,RE)
Trace: UCX$FTPSERVER.LOG;214 1/3 30-MAR-
2004 [DCCSAPFT] (RWED,RWED,RWED,RE)
Trace: Total of 11 files.
Status: Directory listing successful
Command: PWD
Response: 257 U$USLTS1:[DAT.SAP] is current
directory.
Command: TYPE A


But an empty directory is shown.

Regards

Juergen

comment:4 Changed 14 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.