Opened 9 years ago

Closed 3 years ago

Last modified 3 years ago

#5683 closed Feature request (duplicate)

Visually distinguishing sites in tabs (by colour or custom name)"

Reported by: Alexander Hars Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type:
Operating system version:

Description (last modified by Tim Kosse)

The tab feature in the client is great but it also increases mistakes when transferring files to sites with similar directory structures. It happened to me frequently that I dragged a file onto the wrong server because I assumed that a different tab was active. This can be extremely dangerous when transferring to a production web site. Therefore right now I always make sure that I only have one tab open.

A simple way to avoid this would be to allow color-coding sites. The 'General' tab of the site manager would need one additional field with a color-picker where a user could associate a color code with a site.

When the tab for that site is selected, the background color of the client window would change into that color.

Thus I could have three sites open, one with a background color of light green, another with light red, another with light blue. When I select the first one, the gray default background would change to light green. The white background color of the controls, of course, would not change. When I then select the third site, the background color would change to light blue.

Change History (2)

comment:1 Changed 5 years ago by Alexander Schuch

Summary: Visually distinguishing sites in tabsVisually distinguishing sites in tabs (by colour or custom name)"

"it would be a nice feature to be able to add a custom tab name for each connection, rather than having the auto generated ones.

So basically there would be another field in the Site Manager generals tab, that would you let input a 'tab name' that is then displayed in the tab of that particular connection." -- #9569

comment:2 Changed 3 years ago by Tim Kosse

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #7355

Last edited 3 years ago by Tim Kosse (previous) (diff)
Note: See TracTickets for help on using tickets.