Opened 16 years ago

Last modified 14 years ago

#514 closed Bug report

Could not start filezilla ftp server

Reported by: anonymous Owned by:
Priority: normal Component: Other
Keywords: Cc: Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Hello.
I've been using filezilla servers and client on my
computers at work and homw, all working fine (I do not
use any fancy features... just normal plain file xfers).

I restarted my work box today (winXP - after about 2
weeks of uptime), and filezilla server failed to start.
interface cant connect to server. when i try to
manually start filezilla server service I get the
following error message:


Could not start the Filezilla Server FTP server service
on Local Computer.

Error 193: 0xc1


i cant find any help related to that problem and i
would really likke to get it fixed.

i uninstalled filezilla ftp server several times,
downloaded latest version, etc, etc. problem did not go
away.

Change History (3)

comment:1 Changed 16 years ago by anonymous

Logged In: NO

Hello,

I have had exactly the same problem. I have also been using
the server at work for quite a while now with no problems.

I am running W2k SP4 and when I try to start the server
service I get the error message:

"Could not start the Filezilla Server FTP server service
on Local Computer."
"Error 193: %1 is not a valid Win32 application".

Uninstalling/reinstalling/rebooting does not fix the problem.

comment:2 Changed 16 years ago by anonymous

Logged In: NO

Hi again,

I seem to have solved this problem! I searched the Microsoft
website for information on the error messages and came
across Microsoft Knowledge Base Article - 812486 - Event ID
7000 and "%1 Is Not a Valid Win32 Application" Error Message
When You Start a Service.

According to this article, Windows may fail to find the
executable for the service if the path contains spaces. My
PC had a file in the root dir called 'Program', god knows
why?! So Windows was try to execute this file instead of the
service, thus the error message!

I deleted the file and all works fine now.

BTW, the resolution stated in the article is:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>\ImagePath

The ImagePath value contains the path of the executable file
for the service. To add quotation marks around the ImagePath
value for a service:

Click Start, and then click Run.
In the Open box, type regedit, and then click OK.
Locate, and then click the following registry entry, where
<ServiceName> is the name of the service:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<ServiceName>.

For example, if the service is named MyService, locate the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MyService
key.
In the right pane, double-click ImagePath.
In the Value data box, add quotation marks around the
complete path of the executable file for the service.

For example, if the path of the MyService service is
C:\Program Files\MyProgram\MyService.exe, change the entry
in the Value data box for the MyService service to the following
"C:\Program Files\MyProgram\MyService.exe"

Click OK, and then quit Registry Editor.


Hope this information is usefull to others.

comment:3 Changed 14 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.