Opened 10 years ago

Closed 2 years ago

#4863 closed Feature request (duplicate)

Ability to change Server process priority

Reported by: Searinox Owned by:
Priority: high Component: FileZilla Server
Keywords: request server priority cpu Cc:
Component version: Operating system type: Windows
Operating system version:

Description

This one would be a very useful feature especially considering I've seen FZ server use up to 12% CPU on high load. Because the server runs in the background it's always activated. So I don't want it arbitrarily slowing down my computer when I'm doing something intensive. Also I know there are those people out there who would like to have it the other way around and use their server at high prio on dedicated machines.

I don't know what language FZ is written in but in VB it's dead easy to implement such a feature with SetPriorityClass. All itwould need is an entry to read and write to in the .ini advertising the feature, an option with the priority somewhere in the UI, (Realtime, AboveNormal, Normal, BelowNormal, and Low) and a bit of code that would apply the setting at two points - on startup and on saving settings. Sounds like fifteen minutes of work.

Many thanks.

Change History (4)

comment:1 Changed 10 years ago by Searinox

I would like to add a little clarification to this, by "on save settings" I meant on RECEIVING settings by the server when the UI saves them/ :)

comment:2 Changed 2 years ago by Kurt McKee

Triage suggestion

It does not appear that this feature has been implemented in FileZilla Server 0.9.60. In addition, this feature request is eight years old and has had no responses.

If there are no plans to allow users to set the server process priority, I suggest closing this feature request.

comment:3 Changed 2 years ago by Kurt McKee

Duplicate of #2247

comment:4 Changed 2 years ago by Kurt McKee

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.