Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4856 closed Bug report (rejected)

Cannot retrieve directory listing on specific site.

Reported by: Reelix Owned by:
Priority: low Component: FileZilla Client
Keywords: directory listing failure Cc:
Component version: Operating system type: Windows
Operating system version: Windows XP Service Pack 3

Description

There is a specific site that I cannot retrieve the directory listing of, and as such am forced to use an alternate FTP Client (LeechFTP)

Filezilla is my favorite, and works in every instance besides this specific case.

The following is the trace information (URL,IP, and Username Removed):

Status: Resolving address of www.sitenamehere.com
Status: Connecting to IPHERE:21...
Status: Connection established, waiting for welcome message...
Trace: CFtpControlSocket::OnReceive()
Response: 220 Welcome to Brabys.com FTP
Trace: CFtpControlSocket::SendNextCommand()
Command: USER jolene
Trace: CFtpControlSocket::OnReceive()
Response: 331 Password required for usernameHere
Trace: CFtpControlSocket::SendNextCommand()
Command: PASS
Trace: CFtpControlSocket::OnReceive()
Response: 230 Logged on
Trace: CFtpControlSocket::SendNextCommand()
Command: SYST
Trace: CFtpControlSocket::OnReceive()
Response: 215 UNIX emulated by FileZilla
Trace: CFtpControlSocket::SendNextCommand()
Command: FEAT
Trace: CFtpControlSocket::OnReceive()
Response: 211-Features:
Trace: CFtpControlSocket::OnReceive()
Response: MDTM
Response: REST STREAM
Response: SIZE
Trace: CFtpControlSocket::OnReceive()
Response: MLST type*;size*;modify*;
Response: MLSD
Response: UTF8
Response: CLNT
Response: MFMT
Response: 211 End
Status: Connected
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Status: Retrieving directory listing...
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::ChangeDirSend()
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "/" is current directory.
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::ParseSubcommandResult(0)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to I
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (196,34,149,71,207,158)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::SendNextCommand()
Trace: CFtpControlSocket::TransferSend()
Command: MLSD
Trace: CTransferSocket::OnConnect
Trace: CTransferSocket::OnConnect
Trace: CFtpControlSocket::OnReceive()
Response: 425 Can't open data connection.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Trace: CFtpControlSocket::ParseSubcommandResult(2)
Trace: CFtpControlSocket::ListSubcommandResult()
Trace: CFtpControlSocket::ResetOperation(2)
Trace: CControlSocket::ResetOperation(2)
Error: Failed to retrieve directory listing

If any more details are required, they can be supplied.

Enjoy your day!

  • Reelix

Change History (7)

comment:1 Changed 10 years ago by Reelix

Most details have not actually been removed...

comment:2 Changed 10 years ago by Tim Kosse

Priority: blockerlow
Resolution: rejected
Status: newclosed

Almost certainly caused by a broken router and/or firewall interrupting the connection.

You can use http://ftptest.net to figure out if the problem is on the server side of the connection or on your end.

If the problem is on your end, please read http://wiki.filezilla-project.org/Network_Configuration

If the problem is on the server end, you need to contact the server administrator.

comment:3 Changed 10 years ago by Reelix

Status: Resolving address of www.brabys.com

Status: Connecting to 196.34.149.71

Status: Connected, waiting for welcome message

Reply: 220 Welcome to Brabys.com FTP

Status: CLNT http://ftptest.net on behalf of 127.0.0.1

Reply: 200 Don't care

Status: USER jolene

Reply: 331 Password required for jolene

Status: PASS - Removed By Reelix -

Reply: 230 Logged on

Status: FEAT

Reply: 211-Features:

Reply: MDTM

Reply: REST STREAM

Reply: SIZE

Reply: MLST type*;size*;modify*;

Reply: MLSD

Reply: UTF8

Reply: CLNT

Reply: MFMT

Reply: 211 End

Status: PWD

Reply: 257 "/" is current directory.

Status: Current path is /

Status: TYPE I

Reply: 200 Type set to I

Status: PASV

Reply: 227 Entering Passive Mode (196,34,149,71,212,228)

Status: LIST

Error: Could not establish data connection: Connection refused

So, the site can't access it either?

What does that mean?

comment:4 Changed 10 years ago by Reelix

LeechFTP: Yes
Filezilla: No
Manual FTP (Via CMD): Yes
Site: No

...

comment:5 Changed 10 years ago by Tim Kosse

It means that the problem is with the server. You need to contact the server administrator.

comment:6 Changed 10 years ago by Reelix

Surely if the problem was server related, the connection results would be a bit more... random? With some clients having 100% Success, and others having 100% Failure, would that not be a client problem?

comment:7 Changed 10 years ago by Tim Kosse

Different clients use different commands. A proper server works with all clients and all commands.

Note: See TracTickets for help on using tickets.