Opened 10 years ago

Closed 10 years ago

#4799 closed Bug report (duplicate)

Local zip with escaped apostrophe in filename shows as a folder with file inside

Reported by: Darkswitch Owned by:
Priority: normal Component: FileZilla Client
Keywords: local zip apostrophe filename folder Cc:
Component version: Operating system type: Windows
Operating system version: XP Home

Description

When browsing local system files in Filezilla, a zip file with an escaped apostrophe in the filename shows up as a folder (named as everything before the apostrophe, not including the backslash), with it's contents being a zip file (named as the apostrophe onward).

How I encountered the bug:
-Connect to server with files identical to the files stored locally
-Navigate to the zip file's containing folder on the remote host
-Navigate to the zip file's containing folder locally
-The local folder contained identical files as the remote one, except instead of "Guy-123\'s Important Stuff.zip", the local folder contained a folder named "Guy-123", and inside of it was a file named "'s Important Stuff.zip".

Other information:
-The zip file contained a folder named "Guy-123's Important Stuff", without a backslash before the apostrophe.

-In Windows Explorer, the folder with file inside showed up exactly as Filezilla showed it.

-After deleting the folder and contents locally in Windows, and re-copying the zip folder to my local copy of the website in Filezilla, Filezilla created an exact copy of the folder-with-file instance that had previously occurred.

-Using an online control panel, the online zip file's name is also "Guy-123\'s Important Stuff.zip".

Change History (2)

comment:1 Changed 10 years ago by Darkswitch

edit: Using Filezilla v3.2.7.1, but the bug still occurred in v3.2.7

comment:2 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Looks like duplicate of #3227

Note: See TracTickets for help on using tickets.