Opened 10 years ago

Closed 10 years ago

#4800 closed Bug report (duplicate)

Slashes in file names cause incorrect copy to host

Reported by: Jadame Owned by:
Priority: normal Component: FileZilla Client
Keywords: slash ipod transfer Cc:
Component version: Operating system type: Windows
Operating system version: Vista SP2

Description

If you use Filezilla to transfer a file with a / in it from a device that supports them in file names, Filezilla will cut the file name apart and create a directory with the first part and name the file the second part.

This was noticed transferring files from an iPod Touch through SSH onto a Windows Vista machine with Filezilla 3.2.7.1.

Seems to be caused since other filesystems than NTFS and FAT allow "/" as a regular character, as they use "\" for directory structure instead. When transferring, the host OS interpretes the character "\" as indicating a directory.

For example:

Transferring /remote/myfile\'name.txt to C:\localdir\ will create a directory c:\localdir\myfile\, transfer the file there instead, with the name "'name.txt"

Change History (1)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #3227

Note: See TracTickets for help on using tickets.