Opened 10 years ago

Closed 7 years ago

Last modified 4 years ago

#4708 closed Feature request (duplicate)

Windows "Open With..." list in Local

Reported by: Zex Owned by:
Priority: low Component: FileZilla Client
Keywords: open with context dialog windows explorer folder, file-association Cc:
Component version: Operating system type: Windows
Operating system version: Windows XP Professional

Description (last modified by Alexander Schuch)

Greetings,

Excellent application, but it's really painful not to be able to right-click local files and open them in my favorite applications. The "Edit" command usually starts the wrong application. What is needed is "Open With..." dialog like in other Windows apps. Or at least "Explore this folder" to open the folder in Windows Explorer (so I can use it's context menu).

Here's how to display standard "Open With..." dialog for file named "filename" in Windows:

ShellExecute (0, "open", "rundll32.exe", "shell32.dll,OpenAs_RunDLL filename", NULL, SW_SHOW);

For more details about "Open with" dialog check out this article:
http://support.microsoft.com/kb/192352

Thanks for your time and for making this fantastic application.

CroMan

Change History (4)

comment:1 Changed 10 years ago by Tim Kosse

Priority: normallow
Resolution: duplicate
Status: newclosed

Thanks for not using the search function.

#3696

comment:2 Changed 9 years ago by lucato

Resolution: duplicate
Status: closedreopened

Yup, I vote for that too. When we set the selected extension with more than one editor, it would show up the "Open With" and the name of the editors to pick that are assigned to the selected extension file in the "Filetype associations" settings.
Sometimes you want to open in a editor that you get to compare files, other in other editor to translate files and so on. An "Open With" when right-clicking is a must have in FZ. ;0)

comment:3 Changed 7 years ago by Alexander Schuch

Resolution: duplicate
Status: reopenedclosed

This is a duplicate of #3696.

comment:4 Changed 4 years ago by Alexander Schuch

Description: modified (diff)
Keywords: file-association added
Note: See TracTickets for help on using tickets.