Opened 11 years ago

Closed 11 years ago

#3810 closed Bug report (rejected)

queue transfer opens many connection for one file

Reported by: Manfred Baumgartl Owned by:
Priority: normal Component: FileZilla Client
Keywords: transfer abort new connection Cc:
Component version: Operating system type: Windows
Operating system version: Server 2003 SP2

Description

I am transfering one file from a ftp server via queue. The transfer aborts then a new transfer is startet with a new connection on the server. then again and again, till max number of connections to the server is reached. Version 3.1.2 works fine, with no errors or aborts while 3.1.3 doesn't.

The server is pure-ftp on linux based system.

Attachments (1)

FileZila.txt (11.5 KB) - added by Manfred Baumgartl 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

Got logs?

Changed 11 years ago by Manfred Baumgartl

Attachment: FileZila.txt added

comment:2 Changed 11 years ago by Manfred Baumgartl

Status: moreinfonew

Hello!

I have added a log File!

Hope that helps.

Regards

comment:3 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

If you run the network configuration wizard, does the test at the end succeed?

comment:4 Changed 11 years ago by Manfred Baumgartl

Status: moreinfonew

Sorry, I have not used the wizard bevor. This was not neccassery. In other versions. S I will try this for you.

Regards

comment:5 Changed 11 years ago by Manfred Baumgartl

Operating system version: XP SP3Server 2003 SP2

Hello again!

I have made the Test for you, it says:

Connecting to probe.filezilla-project.org
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.1.3
Response: 230 logged on.
Checking for correct external IP address
IP 192.168.3.30 bjc-bgi-d-da
Response: 510 Mismatch. Your IP is xxx.xxx.xxx.xxx, if-bcg-if-cec
Wrong external IP address
Connection closed

That is clearly true, because I am behind a paket filtering machine with masquerading, but both iptables modules for ftp are enabled

ip_nat_ftp
ip_conntrack_ftp

and passive mode works well for me, the last years with other ftp clients also for FileZilla Client 3.1.2.

But there is another thing!!!

I have given you some wrong information, about the host system. I am running a XP SP3 and a Server 2003 SP2 in a VMWARE Server(LINUX)environment, in bridget network mode the problem is on the server 2003 SP2 not on the XP System. The XP System runs well at the same time, same server same file, same direktion(from server to client).

Sorry about the misstake of the operating system. But the error is still there!

Regards

comment:6 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Please understand that I cannot give support for connection related issues if there are network components actively tampering with the FTP connection. The FTP protocol is very fragile in nature and easily breaks down if getting sabotaged.

Note: See TracTickets for help on using tickets.