Opened 11 years ago

Closed 10 years ago

Last modified 6 years ago

#3808 closed Bug report (wontfix)

Bad upload resume

Reported by: Jan Lachnitt Owned by:
Priority: normal Component: FileZilla Client
Keywords: upload resume Cc: pepalogik@…
Component version: Operating system type: Windows
Operating system version: Vista 64-bit SP1, XP SP3

Description

I use a wireless connection which loses some packets so TCP connections are lost quite often. I've installed FileZilla especially for uploading large files because I've heard it resumes uploads correctly. But sometimes it obviously doesn't.

I uploaded a 31MB zip file and found out that the file on the server is a bit larger than the original file. I've retried several times and the resulting file size is each time different but always a bit greater than the correct one. The original file size is 32735774 B and the resulting file size is e.g. (in the logged case) 32763514 B.

I uploaded also a 13MB file and this was uploaded incorrectly for the first time and correctly for the second time so FZ resumes uploads incorrectly only sometimes.

Version: 3.1.3 (2008-09-21)

Attachments (1)

Upload.log (15.3 KB) - added by Jan Lachnitt 11 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by Jan Lachnitt

Attachment: Upload.log added

comment:1 Changed 11 years ago by Jan Lachnitt

Cc: pepalogik@… added

That 13MB file is also damaged, though it has the correct size :-(

comment:2 Changed 11 years ago by Jan Lachnitt

Maybe I should mention I use Comodo firewall but this doesn't seem to break anything.

comment:3 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

What happens if you uninstall the firewall?

comment:4 Changed 11 years ago by Jan Lachnitt

Status: moreinfonew

If I uninstall the firewall, the first what will happen is that Vista will activate its own firewall. I can disable this firewall because

  • I know how to do it,
  • my ISP seems to block all incoming connections so it should be safe to do it.

Should I disable Windows firewall or let it work?

comment:5 Changed 11 years ago by murrayd

Operating system version: Vista 64-bit SP1Vista 64-bit SP1, XP SP3

I'm experiencing the same problem Uploading large files, losing link and auto-resuming multiple times causes data corruption. EXTREMELY annoying and unacceptable.

I have a simple old firewall (Sygate Personal), I doubt the firewall has anything to do with this problem that I doubt. Only occurs with FileZilla. (I've also prepared a debug log in case it's needed)

comment:6 Changed 11 years ago by murrayd

Priority: normalcritical

comment:7 Changed 11 years ago by Tim Kosse

Priority: criticalnormal

comment:8 Changed 11 years ago by Tim Kosse

Unreproducible problem only 2 people have. Hardly critical.

comment:9 Changed 10 years ago by Tim Kosse

Resolution: wontfix
Status: newclosed

To ensure file integrity even on highly unreliable connections such as yours, you want to use FTP over TLS or SFTP instead.

The FTP protocol does not provide any other means to ensure integrity of the transferred data.

Note: See TracTickets for help on using tickets.