Opened 11 years ago

Closed 11 years ago

#3727 closed Bug report (fixed)

Often freezes when downloading updates

Reported by: threexk Owned by: Tim Kosse
Priority: normal Component: FileZilla Client
Keywords: update updates Cc:
Component version: Operating system type: Windows
Operating system version: XP SP3

Description

When updating via Help->Check for updates..., FileZilla attempts to connect to a URL to download the new version, but the progress bar stays empty and FileZilla freezes and the dialog gets "(Not responding)". Killing the FileZilla process and retrying eventually works, but not necessarily on the second try.

Seems like FileZilla might be handling update-download connection failures poorly.

Versions: 3.1.1 and 3.1.1.1 (Not 3.1.2 since there hasn't been an update to download with it yet.)

Sorry I don't have any further details. Hoping someone else has experienced the same problem and can add info.

Attachments (2)

drwtsn32.log (76.2 KB) - added by Brandon Aiken 11 years ago.
da_chicken's Dr. Watson log
user.dmp (28.8 KB) - added by Brandon Aiken 11 years ago.
da_chicken's Dr. Watson dump

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by Tim Kosse

Owner: set to Tim Kosse
Status: reopenedassigned

comment:2 Changed 11 years ago by Tim Kosse

Status: assignedmoreinfo_assigned

Do you have any problems in 3.1.2 if you manually search for and download (but not install) nightly builds? Try it several times in a row to be sure.

comment:3 Changed 11 years ago by rokdd

Operating system version: XP ProfessionalVista

it occured only if running first time the updater.. the file is only created but download hangs... if i would know how to send a log i would do :(

comment:4 Changed 11 years ago by threexk

Status: moreinfo_assignedassigned

Happened again upgrading from 3.1.2 to 3.1.3. Froze the first two times, but worked the third time.

comment:5 Changed 11 years ago by Liam Carver

Operating system version: VistaXP SP3

While upgrading via updater from 3.1.2 to 3.1.3 (seeking a download location), only a zero byte setup-exe was created. Then my whole system froze - finally I had to unplug my machine in order to reboot. Repeating brings the same results. Downloading and upgrading manually works without problems.

comment:6 Changed 11 years ago by Brandon Aiken

I experienced this the first time I tried to update from 3.1.3 to 3.1.3.1. I opened up SysInternal's Process Explorer and the procedure that was eating all the time was in %windir%\System32\msvcrt.dll, which on my XP SP3 system is version 7.0.2600.5512 (xpsp.080413-2111).

Also using Process Explorer, I attached Dr. Watson to the process, which initated a dump. I've attached both the drwatsn32.log and user.dmp.

Closing FileZilla for a few minutes and restarting it allowed the auto-update to restart and complete with no issues.

Changed 11 years ago by Brandon Aiken

Attachment: drwtsn32.log added

da_chicken's Dr. Watson log

Changed 11 years ago by Brandon Aiken

Attachment: user.dmp added

da_chicken's Dr. Watson dump

comment:7 Changed 11 years ago by Tim Kosse

Resolution: fixed
Status: assignedclosed

I've finally been able to reproduce it. After that, fixing it took no more than 5 minutes.

Fix will be in 3.1.4, you might have to upgrade to that version (once released) manually one more time.

Note: See TracTickets for help on using tickets.