Opened 12 years ago

Last modified 6 years ago

#3290 closed Bug report

file gets uploaded twice

Reported by: adeljohn67 Owned by: Alexander Schuch
Priority: normal Component: Other
Keywords: Cc: adeljohn67, Alexander Schuch, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

I am using filezilla for the very first time
and think I have a bug when using the program
to transfer files.

I tried to upload files to my ISP webspce and
the bug seems to be that when sending a file
it sends the same file twice.

is this supposed to happen or not?

Attachments (1)

filezilla.log (19.8 KB) - added by adeljohn67 12 years ago.
Filezilla Transfer log

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Alexander Schuch

It basically is not supposed to happen. Anyway, we lack some more information. Which version of FileZilla are you using? The latest one is FileZilla 3.0.1. If you are using an older version, please update and try to re-produce the problem.

Without a full log it is not possible to understand what might be going on, so...
"Add complete logs using logging level 3. You can set the debug level in the settings dialog of FileZilla Client. Do not obfuscate the log in any way, in particular leave all IP addresses intact. Feel free to mark your bug report as 'Private' instead."

comment:2 Changed 12 years ago by adeljohn67

My version of Filezilla is in fact 3.0.1
which I downloaded from the Filezilla web site.

I can't find the option to get the log file. There is a debug menu but that only has 2 options to clear cache
or crash..... I tried reproducting the bug and it happened again. This might be of some help but it only seems
to be happening to .jpg files... most other files get transferred only once..

comment:3 Changed 12 years ago by Alexander Schuch

In the setting in "debug" category, you set logging level to 3. Then, you reproduce the error and copy'n'paste the whole message log into a file. You then attach the file here, and if needed, mark the bug report as "private".

Changed 12 years ago by adeljohn67

Attachment: filezilla.log added

Filezilla Transfer log

comment:4 Changed 12 years ago by adeljohn67

Please attach some logs showing the problematic behaviour.

The logs should be made using debug level 3 which can be enabled
on the debug page in the settings dialog of FileZilla.

The logs have to be complete and unmodified. Do not attempt to
remove or obfuscate any information you might find irrelevant.

If you are worried about posting IP addresses or other
confidential information, mark the tracker item as private.

comment:5 Changed 12 years ago by adeljohn67

I shall try again to get a log file for you.

My versio of Filezilla is 3.0.1

OK added file. I think this might be the file you are after.
File Added: filezilla.log

comment:6 Changed 12 years ago by Tim Kosse

This very much looks like an issue with a broken router or firewall which closes the control connection prematurely.

Please disable all firewall and if you're using Windows, terminate the "Application Layer Gateway service" (it's only useful if your system performs as NAT router itself, it is harmful in all other cases)

comment:7 Changed 12 years ago by adeljohn67

Problem appears to be fixed...

When you mentioned firewall I just remembered the one that is part of Windows
and Filezilla wasn't in the list of "exceptions" which the firewall should
not block. I added that to the list and the problem I was having no longer
appears to be happening.

Note: See TracTickets for help on using tickets.