Opened 13 years ago

Last modified 7 years ago

#3289 closed Bug report

Crashes when uploading through SFTP

Reported by: stingbat Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: stingbat, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

FileZilla "crashes" sometimes, when trying to upload through SFTP. When approx. 200+ files or end of queue, it can without no reason simply crash.

Happend while trying to upload Wordpress 2.3, which then had to be tried a few times, before succeed.

For reproduce, try either upload the folders wp-admin+wp-content or wp-includes.

Attached some more details (zipped), hope it helps a bit.

Attachments (3)

FileZilla.zip (34.4 KB ) - added by stingbat 13 years ago.
Screenshots + appcompat
FileZilla(2).zip (33.1 KB ) - added by stingbat 13 years ago.
Screenshots (part II)
FileZilla-3.png (16.7 KB ) - added by stingbat 13 years ago.
Screenshot (shutdown/close part)

Download all attachments as: .zip

Change History (13)

by stingbat, 13 years ago

Attachment: FileZilla.zip added

Screenshots + appcompat

comment:1 by stingbat, 13 years ago

(using FileZilla 3.0.1 on Windows XP)

comment:2 by Tim Kosse, 13 years ago

Please try the most recent nightly build from http://filezilla-project.org/nightly.php

by stingbat, 13 years ago

Attachment: FileZilla(2).zip added

Screenshots (part II)

comment:3 by stingbat, 13 years ago

Have tried again (using build 2007-10-09), but seems like it still happens, when uploading through SFTP.
Would like to give more details if I'm able to - is there any debug-mode-thingy?
Thanks!
File Added: FileZilla(2).zip

comment:4 by Tim Kosse, 13 years ago

Please describe how you are starting the transfer.

Furthermore, what's the number of simultaneous transfers and uploads set to in the settings?

comment:5 by stingbat, 13 years ago

Simply dragging the folders from the local part to the remote part, within FileZilla.

Then it transfers like it should for about 200 files, and then crashes...

The simulaneous transfers are set to 2 (the default value), upload to 0 (the default value).

...

Tried today to change simulaneous transfers to 1, which worked out fine. Afterwards I set it back to 2, and haven't been able to make it crash. Don't know if it has anything to do, or if today is just "special". Will make some more test, and return with an update.

comment:6 by Tim Kosse, 13 years ago

I cannot reproduce it here on multiple different machines and you appear to be no longer able to reproduce it. This is a good indication of a (temporary) problem with your system as apposed to a bug in FileZilla. So I'm closing this.

comment:7 by stingbat, 13 years ago

Actually happend again today.
It seems to happen, if it sends too many files per sec/goes too fast. But it's hard to figure out exactly what goes wrong.

Any suggestion on what I could try, to find out what creates the problems?

by stingbat, 13 years ago

Attachment: FileZilla-3.png added

Screenshot (shutdown/close part)

comment:8 by stingbat, 13 years ago

Got a new likely bug, don't know if it's actually related.
After uploading a bit and moving around (on SFTP), it crashed when I closed FileZilla.
File Added: FileZilla-3.png

comment:9 by Tim Kosse, 13 years ago

Please try the upcoming 2007-10-14 nightly from http://filezilla-project.org/nightly.php

Also, what processor do you have?

comment:10 by sf-robot, 13 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.