Opened 14 years ago

Last modified 14 years ago

#3084 closed Bug report

create directory on server not working

Reported by: josh_b Owned by: Tim Kosse
Priority: normal Component: Other
Keywords: Cc: josh_b, Tim Kosse, Alexander Schuch
Component version: Operating system type:
Operating system version:

Description

When I right-click in the server's file browser and select 'create directory' the proper dialog comes up, asking for a name/path for the new directory. However, upon completing this dialog, nothing happens. I tried refreshing the file browser view, but the directory was not created.

I also connected to the same server using the previous version of FZ, just to confirm that the directory had not been created. It hadn't.

Change History (5)

comment:1 by Alexander Schuch, 14 years ago

Can you please give some more information? What name did you enter? What was shown in the message log? Did the server return any error? Were you using FileZilla 3 beta 2 or a nightly build?

comment:2 by josh_b, 14 years ago

I tried a few directory names, none of which worked. 'test' 'dir' and 'New Folder' Nothing worked.

To be completely specific, the complete text entered into the Create Directory dialog was '/home/myusername/public_html/New folder/'.

In each case the message log showed:
Status: Creating directory '/home/myusername/public_html/XXXXX/'...

where XXXXX was the folder name I typed in. No other status or error messages were generated by this command. In short, all behavior was as I expected, except that the directory didn't actually get created.

I'm using FZ 3, beta 2. I didn't put that info in because I thought this section was only for bug reports relating to the beta 2 release. I'll be sure to include that from now on.

Thanks.

comment:3 by josh_b, 14 years ago

Oh, and I'm running WinXP. (sheepishly admitting that I only now read the DOs and DON'T list of submitting bugs)

Here's the message log, with debugging set to verbose:

Status: Creating directory '/home/burnetts/public_html/New folder/'...
Trace: CSftpControlSocket::SendNextCommand(0)
Trace: /home/nightlybuild/buildroot/packages/FileZilla3/src/engine/sftpcontrolsocket.cpp
Trace: CSftpControlSocket::ResetOperation(130)
Trace: CControlSocket::ResetOperation(130)

comment:4 by Tim Kosse, 14 years ago

Please try the most recent nightly from http://filezilla-project.org/nightly.php

comment:5 by josh_b, 14 years ago

Confirmed, fixed in the 2006-11-29 nightly. Thanks.

Note: See TracTickets for help on using tickets.