Opened 6 months ago

Closed 6 months ago

#12905 closed Bug report (worksforme)

Filezilla Error On Illegal Windows Characters

Reported by: DLdrrr3 Owned by:
Priority: normal Component: FileZilla Client
Keywords: illegal characters Cc:
Component version: Operating system type: Windows
Operating system version:


FileZilla Client


Build information:

Compiled for: x86_64-w64-mingw32
Compiled on: x86_64-pc-linux-gnu
Build date: 2023-03-03
Compiled with: x86_64-w64-mingw32-gcc (GCC) 10-win32 20210110
Compiler flags: -O2 -g -Wall -Wextra -Wno-deprecated-copy -ffunction-sections -fdata-sections -Wno-cast-function-type

Linked against:

wxWidgets: 3.2.1
SQLite: 3.39.4
GnuTLS: 3.8.0

Operating system:

Name: Windows 11 (build 22621), 64-bit edition
Version: 10.0
Platform: 64-bit system
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 aes pclmulqdq rdrnd bmi bmi2 adx lm
Settings dir: C:\Users\TR\AppData\Roaming\FileZilla\

Issue-This version of Filezilla is not handling illegal characters correctly. Previous versions have not had this specific trouble to replace illegal characters from the server while transferring to a Windows system.

The attached screenshot shows 3 files that failed transfer from server to Windows directory due to the illegal Windows character colon (:) present in the 3 files. The first transfer initiated using the filezilla preference of Automatic for FTP File Types resulted in the 3 files failing.

When I changed the Filezilla preference to Binary for FTP File Types and retried the folder download, the same 3 files failed.

This is not correct behavior and is also strange because in the Filezilla queue area the illegal character colon has been replaced with underscore. You can confirm that the illegal character exists on the server by reviewing the 2 highlighted files on the server side of Filezilla remote window.

Local Directory

"T:\pathfinder\199800 Fantastic Four 1_2 (Wizard).cbr"
"T:\pathfinder\199800 Generation X 1_2 02 of 02 covers.cbz"
"T:\pathfinder\199800 Spider-Man 1_2 (Wizard) 02 of 02 covers.cbz"

Remote Directory

"\199800 Fantastic Four 1:2 (Wizard).cbr"
"\199800 Generation X 1:2 02 of 02 covers.cbz"
"\199800 Spider-Man 1:2 (Wizard) 02 of 02 covers.cbz"

Note: When I initially tried to download multiple directories that contained illegal characters, filezilla basically crashed (no further input or output from filezilla window). Filezilla needed to be closed completely and restarted in order to resume normal operations.

By trial and error I was able to figure out that the illegal characters in the directories was what Filezilla took issue with. I decided to download the files individually from the server to see if it could complete successfully and they did. (See the 3 files outside of the directories in the screenshot). So, Filezilla can transfer files with illegal characters correctly individually, but from within a directory queue Filezilla is failing to transfer correctly.

I also confirmed that the files could be downloaded successfully with the illegal characters replaced by installing WinSCP and queuing the 5 directories I tried with Filezilla. All directories were successfully downloaded using the Automatic File Type preference and the illegal colon (:) characters were replaced with %3A.

Attachments (1)

04-15-2023_154443.png (220.5 KB ) - added by DLdrrr3 6 months ago.

Download all attachments as: .zip

Change History (2)

by DLdrrr3, 6 months ago

Attachment: 04-15-2023_154443.png added

comment:1 by Tim Kosse, 6 months ago

Priority: criticalnormal
Resolution: worksforme
Status: newclosed

Cannot reproduce. If you look at the queue you can even see that the characters have been replaced by underscores in the local file names.

Note: See TracTickets for help on using tickets.