Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#12164 closed Bug report (fixed)

Version 3.48.0 client cant open or view a pdf anymore

Reported by: Wes Owned by:
Priority: normal Component: FileZilla Client
Keywords: pdf, file associations Cc:
Component version: ? Operating system type: Windows
Operating system version: 7

Description

I have tried putting the path in file associations but it doesnt work transfers to somewhere,I dont know where tho. Its many different pdfs, not just one. If I dont specifiy a path in file associations it tries to load in my default which is notepad++

Change History (3)

comment:1 by justinkb, 3 months ago

I believe these and all other recently reported bugs about file associations are caused by the associations "database" getting mangled when it is changed programmatically by FileZilla.

Look at the following:

html C:\Windows\system32\NOTEPAD.EXE %fini C:\Windows\system32\NOTEPAD.EXE %finstall C:\Windows\system32\NOTEPAD.EXE %fjpg C:\Windows\system32\mspaint.exe %fjson C:\Windows\system32\NOTEPAD.EXE %ftxt C:\Windows\system32\NOTEPAD.EXE %f

Workaround until this is fixed: manually add hard returns whenever you add a new file type to this field programmatically (and it gets mangled)

edit: Quick glance at recent revisions makes me suspect r9744 as the culprit

Last edited 3 months ago by justinkb (previous) (diff)

comment:2 by Tim Kosse, 3 months ago

Resolution: fixed
Status: newclosed

Thanks, will be fixed in the next version.

comment:3 by Tim Kosse, 3 months ago

Please try 3.48.1-rc1

Note: See TracTickets for help on using tickets.