Opened 6 months ago

Last modified 6 months ago

#12163 reopened Bug report

"Local site" gives "(some path) does not exist or cannot be accessed." error for some folders on mounted CIFS shares

Reported by: sts_pro Owned by:
Priority: high Component: FileZilla Client
Keywords: CIFS, does not exist or cannot be accessed Cc: guzmelek@…
Component version: 3.47.2.1 Operating system type: Linux
Operating system version: Linux 4.19.97-v7l+ armv7l (Raspbian)

Description

This issue happens intermittently, this happens:

  • only for some folders on mounted CIFS shares
  • only sometimes: same folders can be accessed one moment but become unreachable a minute later
  • only in "Local site" view: at the same time client successfully continues downloads in the same folder and can Import/Export configurations from/to the same folders

I haven't been able to find reflection of error in any of the logs: /var/log/messages, kern.log, syslog, built-in Filezilla Logging from the Settings does not have any traces.

Attachments (2)

screenshot.jpg (138.4 KB ) - added by sts_pro 6 months ago.
screenshots
screenshots2.jpg (266.7 KB ) - added by sts_pro 6 months ago.

Download all attachments as: .zip

Change History (9)

by sts_pro, 6 months ago

Attachment: screenshot.jpg added

screenshots

comment:1 by Tim Kosse, 6 months ago

Resolution: worksforme
Status: newclosed

The screenshot shows different paths being used in the local file list and in the file picker.

by sts_pro, 6 months ago

Attachment: screenshots2.jpg added

comment:2 by sts_pro, 6 months ago

Issue is not fixed, attaching another set of screenshots (screenshots2.jpg). I used another example folder, this time I made sure all paths are even looking the same (on the previous screenshot it was indeed the same path and it was just a symbolic link inside the 4TB directory, pointing to the same /media/Pers. Now, I removed symbolic links out of equation and used /media/shared for all three screenshots)

Last edited 6 months ago by sts_pro (previous) (diff)

comment:3 by sts_pro, 6 months ago

Resolution: worksforme
Status: closedreopened

comment:4 by Tim Kosse, 6 months ago

Status: reopenedmoreinfo_reopened

That is odd. When you get the error message, please use the following command in a terminal and post its output: ls -la /media

comment:5 by sts_pro, 6 months ago

Status: moreinfo_reopenedreopened

I agree this is quite odd. Here is the output:

pi@pi:/media $  ls -la /media
total 252
drwxr-xr-x   8 pi   root   4096 Feb  8 01:19 .
drwxr-xr-x  24 root root   4096 Mar 30 22:23 ..
drwxr-xr-x   2 pi   root   4096 May  3 15:59 4Tb
drwxr-xr-x   2 root root  32768 May  6 15:38 Download
drwxr-xr-x   2 root root 196608 Apr 15 06:34 Films
drwx---rwx   1 root root   4096 May  5 21:28 Pers
drwxrwxrwx+  2 pi   pi     4096 Feb  8 01:18 pi
drwxr-xr-x   2 root root   4096 May  5 20:53 shared

comment:6 by Tim Kosse, 6 months ago

Status: reopenedmoreinfo_reopened

What is the origin of your FileZilla binaries? Is it from the official binaries distributed over our website, some third-party distribution or self-compiled?

comment:7 by sts_pro, 6 months ago

Status: moreinfo_reopenedreopened

First installation was from the official Raspbian APT repo, quite an outdated version. I thought error could be caused by it.
Second installation was self-compiled, using sources from your web site.

I understand the issue could be actually caused not by FileZilla itself but rather by cifs-utils or any other related package.
Please let me know if you need any logs or any repro steps I should follow.

Note: See TracTickets for help on using tickets.