Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#12165 closed Bug report (fixed)

FZ 3.48.0: "Opening Failed" error message

Reported by: mrkgnao Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.48.0 Operating system type: Windows
Operating system version: 7

Description

The following bug has appeared today, immediately after I had upgraded Filezilla to version 3.48.0. It didn't happen with previous versions (I have been using FZ daily for years --- thank you for creating this wonderful tool).

Now, whenever I doubleclick a LOCAL file in order to edit it, I get an error message popup reading "Opening failed: The file '[FILENAME HERE]' could not be opened: The associated command failed" (+ OK button). This is a spurious error message, as the file does open just fine. This happens with every local file I try to edit, forcing me to close this popup on every local file edit (a very common occurrence for me). It does not happen with files on the server.

My relevant settings are:

  • File lists -> Double-click action on files -> View/Edit
  • File editing -> Default editor -> use custom editor -> "C:\Program Files (x86)\Vim\vim74\gvim.exe"
  • File editing -> Always use default editor

Additional observation:

  • If instead of double clicking the local file, I right click it and select "Edit" the same error appears. However, if I select "Open" it does not.

P.S. Also posted this on the forum.

Change History (4)

comment:1 by justinkb, 3 months ago

Dupe of 12164, see my comment here for more info

https://trac.filezilla-project.org/ticket/12164#comment:1

Workaround for now is manually fixing the mangled associations text field by entering hard returns whenever you've added to it

comment:2 by mrkgnao, 3 months ago

I don't believe it is exactly the same issue. My filetype association table is empty. I use "always use default editor".

comment:3 by Tim Kosse, 3 months ago

Resolution: fixed
Status: newclosed

Please try 3.48.1-rc1

comment:4 by tuxun, 3 months ago

@filezilla: please stop to share the 3.48.0 version, as its bugged AND sponsored.

@mrkgnao: the 3.48.1 version is hidden on this page and should fix your problem( https://filezilla-project.org/download.php?show_all=1 )

Note: See TracTickets for help on using tickets.