Opened 4 months ago

Closed 4 months ago

#12162 closed Bug report (fixed)

Client build fails on aarch64 because of incomplete putty source

Reported by: Christian Weisgerber Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.47.2.1 Operating system type: BSD
Operating system version:

Description

Building the FileZilla client fails on aarch64 as observed on OpenBSD/arm64, but the problem is generic and should affect all Unix-style operating systems on aarch64 (64-bit ARM).

ld: error: undefined symbol: platform_aes_hw_available

referenced by sshaes.c

libfzputtycommon_a-sshaes.o:(aes_hw_new) in archive libfzputtycommon.a

...

Linking fails because the functions

platform_aes_hw_available()
platform_sha1_hw_available()
platform_sha256_hw_available()

are undefined.

The problem is in the included putty source. On aarch64 (#if HW_AES == HW_AES_NEON), the missing functions are called from sshaes.c, sshsha.c, sshsh256.c. In the original putty source, they are provided by unix/uxutils.c. However that file was omitted when the putty source was included in FileZilla.

Simply adding putty's unix/uxutils.c and adding it in Makefile.am will fix the problem.

Change History (1)

comment:1 by Tim Kosse, 4 months ago

Resolution: fixed
Status: newclosed

Thanks, will be fixed in 3.48.0

Note: See TracTickets for help on using tickets.