#11583 closed Bug report (rejected)

Windows 10 1803 - Drag and drop problem

Reported by: nc_pt Owned by:
Priority: normal Component: FileZilla Client
Keywords: drag drop explorer windows Cc:
Component version: 3.32.0 Operating system type: Windows
Operating system version: 10 v1803 (64 bits)

Description

My windows laptop recently got updated to windows 10 1803 (x64).

Since then I lost the ability to drag and drop files to windows explorer.

I get the message:

"Could not determine the target of the Drag&Drop operation.
Either the shell extension is not installed properly or you didn't drop the files into an Explorer window."

I've tried register the extension (fzshellext_64.dll), rebooted, re-installed, installed both 32 and 64 bit versions and nothing.

Attachments (2)

filezilla.PNG (7.0 KB) - added by nc_pt 18 months ago.
Error Message
windows_10.PNG (5.2 KB) - added by nc_pt 18 months ago.
Windows Version

Download all attachments as: .zip

Change History (7)

Changed 18 months ago by nc_pt

Attachment: filezilla.PNG added

Error Message

Changed 18 months ago by nc_pt

Attachment: windows_10.PNG added

Windows Version

comment:1 Changed 18 months ago by Tim Kosse

Resolution: rejected
Status: newclosed

Confirmed, however it is not a bug in FileZilla, it is a bug in Windows. Please contact Microsoft for assistance as only they can fix it.

comment:2 Changed 18 months ago by Tim Kosse

Microsoft broke the CopyCallback function on the ICopyHook interface, the pszDestFile argument is now an empty string instead of the target filename of the drag&drop operation.

Last edited 18 months ago by Tim Kosse (previous) (diff)

comment:3 Changed 13 months ago by nc_pt

Regarding this issue, and after seeing a Filezilla Developer assuming that "1803 update actually fixed an incorrect Explorer behaviour" here:

https://social.msdn.microsoft.com/Forums/en-US/99525cc5-9b80-4c18-b81b-d36703a701a0/after-windows-1803-update-icopyhookcopycallback-pszdestfile-parameter-comes-empty?forum=windowsgeneraldevelopmentissues

I was wondering if this bug can be reopened and if there are any plans on fixing it.

Thanks in advance

comment:4 Changed 13 months ago by nc_pt

Resolution: rejected
Status: closedreopened

comment:5 Changed 13 months ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

No. It's a bug in Windows 1803. Don't use Windows 1803. Microsoft itself recommends not using it: https://twitter.com/MicrosoftHelps/status/1041750130993577984

Note: See TracTickets for help on using tickets.