Opened 5 years ago

Closed 5 years ago

#10317 closed Bug report (fixed)

.DBF file arrives damaged with 3.10.2

Reported by: IC2 Owned by:
Priority: blocker Component: FileZilla Client
Keywords: damaged dbf file Cc:
Component version: Operating system type: Windows
Operating system version: 8.1

Description

Since we upgraded to 3.10.2 DBF files arrive damaged. After a few records the content and fields seems shifted somehow. Additional problem is that we can't go back to an earlier version of Filezilla easily as the passwords are now crypted (good thing...) but in the previous version they weren't. See the damage in the picture, from record 81. The original DBF is attached too; you should be able to read it in Excel for example.

Dick

Attachments (2)

landcode.dbf (44.6 KB) - added by IC2 5 years ago.
DBF sample which is damaged. Pic not uploadable (I can only upload 1 file)
DamagedDBF.JPG (162.4 KB) - added by IC2 5 years ago.
Second file here!

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by IC2

Attachment: landcode.dbf added

DBF sample which is damaged. Pic not uploadable (I can only upload 1 file)

Changed 5 years ago by IC2

Attachment: DamagedDBF.JPG added

Second file here!

comment:1 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

Are there any transfer errors displayed in the message log?

Which FTP server software (produce and version) is running on the server?

Do you use speed limits in FileZilla?

comment:2 Changed 5 years ago by IC2

Status: moreinfonew

Apparently I have to login to reply, which is very inconvenient (I replied per mail).
This is what I wrote:

Are there any transfer errors displayed in the message log?

No:

Status: File transfer successful, transferred 45.699 bytes in 1 second
Status: Retrieving directory listing of "/"...
Status: Directory listing of "/" successful

Which FTP server software (produce and version) is running on the server?

No idea; it's a shared Windows server from an ISP.

Do you use speed limits in FileZilla?

No. I didn't change anything in the Filezilla configuration when I upgraded to the lastest version. In fact, I don't think I ever changed any setting at all from the default. This has always worked (we FTP dbf files a lot). Also note that we have our own FTP routines written based upon the Chilkat components; this transfers the files still without problems.

Did you already try uploading the dbf yourself?

comment:3 Changed 5 years ago by IC2

Resolution: fixed
Status: newclosed

I found the cause - and it's NOT Filezilla but virus scanner AVG, after an update around the same time as my Filezilla update. This is the only thing which helped (From AVG's support forum https://support.avg.com/answers?s=ftp#!/feedtype=SINGLE_QUESTION_DETAIL&dc=Windows&criteria=ALLQUESTIONS&id=906b00000004fNYAAY)

  • Navigate to C:\Windows\system32\drivers\ and rename this driver from 'avgwfp*.sys' to 'avgwfp*.sys.old'
  • Reboot the machine

I found that 1 of our FTP programs wasn't affected by this but Filezilla and later one other was, and not even for all file types. Not sure what this driver was/is doing but it looks like after renaming Filezilla worked again flawless as did uploads with the other affected program.

Thanks for looking into it, I hope this helps others.

Note: See TracTickets for help on using tickets.