Opened 5 years ago

Closed 5 years ago

#10157 closed Bug report (duplicate)

MLSD timeout after upgrade to 3.10.0.2

Reported by: kgshultz Owned by:
Priority: normal Component: FileZilla Client
Keywords: MLSD timeout Cc:
Component version: Operating system type: OS X
Operating system version: 10.10.1

Description

If I download the FileZilla version from the filezilla-project.org website (through Source Forge), that works fine on my computer. That is version is 3.9.0.6. However, when I install it I get a message saying that there's a new version (3.10.0.2). If I upgrade to 3.10.0.2, suddenly FileZilla times out after the MLSD command.

Here is the information I get when trying to use version 3.10.0.2 that results in a timeout:

Status: Resolving address of ftp.kgshultz.com
Status: Connecting to 69.195.124.172:21...
Status: Connection established, waiting for welcome message...
Status: Initializing TLS...
Status: Verifying certificate...
Status: TLS connection established.
Status: Server does not support non-ASCII characters.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (69,195,124,172,100,165)
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

I did some searching around online and found lots of people saying that MLSD timeouts might be because there was a problem with my router. I tried logging on in several different locations with different routers, and I still have the same problem. Not to mention, it works fine using version 3.9.0.6.

I'm at a bit of a loss now and the only solution I've found is to stick with version 3.9.0.6. I'm nervous that there will be another upgrade (beyond 3.10.0.2) that will cause me the same problems, but I will no longer be able to download 3.9.0.6 from the website.

Change History (1)

comment:1 Changed 5 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #9995

Note: See TracTickets for help on using tickets.