Opened 5 years ago

Closed 4 years ago

#9998 closed Bug report (duplicate)

After 3.10.0 Update, can no longer update files

Reported by: Mark D. Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: mark.dagosta@…
Component version: Operating system type: Windows
Operating system version: 8.1

Description

After installing v3.10.0, every file upload attempt fails with "Could not start transfer".

Change History (6)

comment:1 Changed 5 years ago by Tim Kosse

Priority: criticalnormal
Resolution: rejected
Status: newclosed

Your server isn't configured correctly for FTP over TLS.

Contact your server administrator or server hosting provider for assistance so that the server configuration can be fixed.

comment:2 Changed 5 years ago by Mark D.

Resolution: rejected
Status: closedreopened

Wait... you put out a new release... tons of people report that your product no longer works for them... you close all these bug reports with a status of "Rejected"... and tell us all that it's OUR problem? I love your product and appreciate the work that goes into maintaining it for all of us to use for free. But can you at least explain a bit about what YOU changed that triggered this particular problem? So that we can speak more intelligently to our server hosting providers...

comment:3 Changed 5 years ago by Sauron

I'm having exactly the same issue when using SFTP on all platforms except for Windows...
Every SFTP transfer fails with "open for write: permission denied" if I try to overwrite/update a file, even when just uploading the same file twice in a row to my home folder.
Using Windows it works perfectly fine using 3.10.0, but on Linux and Mac OS X the only solution is to manually delete the old files before uploading new ones - or to downgrade to 3.9.0.6.

comment:4 Changed 5 years ago by Sauron

Operating system type: Windows
Operating system version: 8.1
Priority: normalhigh

Still not working with 3.10.0.1. This is a pretty nasty regression.

How to reproduce:

  1. Connect to a server using SFTP.
  2. Upload a file to a folder in which you have write access (such as ~).
  3. Upload the same file again - the "destination exists" window pops up.
  4. Choose the default action, Overwrite, and click OK.
  5. FileZilla reports "Error: /name/of/file: open for write: permission denied" and the destination exists window pops up once again. The only way to replace the file is to delete it before uploading the new one.

comment:5 Changed 5 years ago by Sauron

Operating system type: Windows
Operating system version: 8.1
Priority: highnormal

Sorry for hijacking this bug report! My issue was fixed in 3.10.0.2 and was apparently *nix specific, meaning it was totally unrelated to this bug... Putting it back like it was before.

comment:6 Changed 4 years ago by Tim Kosse

Resolution: duplicate
Status: reopenedclosed

Duplicate of #9995

Note: See TracTickets for help on using tickets.