Opened 6 years ago

Closed 5 years ago

#9957 closed Bug report (outdated)

Filezilla freezes in Ubuntu 14.10

Reported by: Kenneth Rasmussen Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Linux
Operating system version: Ubuntu 14.10 64 bit

Description (last modified by Tim Kosse)

In Ubuntu 14.10 if i connect to an ftp server and start renaming the files suddenly filezilla wont allow me to type anything. This bug dosent exist in Ubuntu 14.04 64 bit.

i use F2 to rename files and this is still possible to use. Also i can click in the name of a file and move the marker and mark text with the mouse, but i cant erase the names or type new text in the names. This happend very shortly after.
If i connect to the ftp find a file and mark it for editing/renaming and go over in a browser or folder on my machine suddenly when i come back filezilla kinda freezes.. only thing to do is close filezilla and start it again and this happens everytime.. i cant even have filezilla open for 5 minutes and conencted..

Im running Ubuntu 64 bit and my local network is stable (Using lan cables and have transfer speeds on 100 MB/s (1000 Mbit)

I tried to debug filezilla, but the debug dosent catch anything related to what im doing.. (i will try to get some debug/logging that could be useful, but maby you just need to run Ubuntu 14.10 64 bit and rename files on your ftp.. when i enabled debug/logging it took longer time before it did freeze.

Attachments (2)

filezilla.log (933 bytes ) - added by Kenneth Rasmussen 6 years ago.
a log where you can see i was editing a file when it did freeze (didnt finish)
filezilla.2.log (7.4 KB ) - added by Kenneth Rasmussen 6 years ago.
highest debug level, failed after first log (after first log it got to work again, but not this time)

Download all attachments as: .zip

Change History (6)

by Kenneth Rasmussen, 6 years ago

Attachment: filezilla.log added

a log where you can see i was editing a file when it did freeze (didnt finish)

by Kenneth Rasmussen, 6 years ago

Attachment: filezilla.2.log added

highest debug level, failed after first log (after first log it got to work again, but not this time)

comment:1 by Tim Kosse, 6 years ago

Priority: criticalhigh

comment:2 by Tim Kosse, 6 years ago

Resolution: worksforme
Status: newclosed

Are you using the FileZilla binaries from https://filezilla-project.org/ or the FileZilla package that is part of your distribution?

In the latter case, this issue is most likely caused by an outdated wxWidgets library. You need to update to wxWidgets 3.0.2 or later.

In the former case, please reopen this ticket if you are using the most recent version of FileZilla.

comment:3 by Kenneth Rasmussen, 6 years ago

Resolution: worksforme
Status: closedreopened

kenneth@kenneth-W54-55SU1-SUW:~$ apt-cache depends filezilla && apt-cache policy libwxgtk3.0-0 libwxbase3.0-0
filezilla

Afhængigheder: libc6
Afhængigheder: libdbus-1-3
Afhængigheder: libgcc1
Afhængigheder: libglib2.0-0
Afhængigheder: libgnutls-deb0-28
Afhængigheder: libidn11
Afhængigheder: libsqlite3-0
Afhængigheder: libstdc++6
Afhængigheder: libtinyxml2.6.2
Afhængigheder: libwxbase3.0-0
Afhængigheder: libwxgtk3.0-0
Afhængigheder: filezilla-common
Anbefalede: xdg-utils
Konflikter: filezilla:i386

libwxgtk3.0-0:

Installeret: 3.0.2-1~ppa2
Kandidat: 3.0.2-1~ppa2
Versionstabel:

* 3.0.2-1~ppa2 0

500 http://ppa.launchpad.net/n-muench/programs-ppa/ubuntu/ utopic/main amd64 Packages
100 /var/lib/dpkg/status

3.0.1-3 0

500 http://archive.ubuntu.com/ubuntu/ utopic/universe amd64 Packages

libwxbase3.0-0:

Installeret: 3.0.2-1~ppa2
Kandidat: 3.0.2-1~ppa2
Versionstabel:

* 3.0.2-1~ppa2 0

500 http://ppa.launchpad.net/n-muench/programs-ppa/ubuntu/ utopic/main amd64 Packages
100 /var/lib/dpkg/status

3.0.1-3 0

500 http://archive.ubuntu.com/ubuntu/ utopic/universe amd64 Packages

But now it wont let me edit files instantly

comment:4 by Tim Kosse, 5 years ago

Description: modified (diff)
Resolution: outdated
Status: reopenedclosed

Please update to the most recent version of FileZilla, we cannot support outdated versions.

Note: See TracTickets for help on using tickets.