Opened 5 years ago

Closed 3 years ago

#9953 closed Bug report (outdated)

Appcrash

Reported by: lostinlodos Owned by:
Priority: normal Component: FileZilla Client
Keywords: crash, security, memory Cc:
Component version: Operating system type: Windows
Operating system version: 6.1:7601 Windows 7 ultimate x64

Description

Crash on load
Problem signature:

Problem Event Name: APPCRASH
Application Name: filezilla.exe
Application Version: 3.10.0.0
Application Timestamp: 00000006
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.18247
Fault Module Timestamp: 521ea8e7
Exception Code: c0000005
Exception Offset: 0002e3be
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Change History (6)

comment:1 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

Which version of FileZilla are you using?

What did you do with FileZilla when it crashed?

Can you reproduce the crash? If so, what are the steps to reproduce it?

comment:2 Changed 5 years ago by Jarek

Got same situation here on latest Beta 3

System

  • Provider [ Name] Application Error
  • EventID 1000 [ Qualifiers] 0 Level 2 Task 100 Keywords 0x80000000000000
  • TimeCreated [ SystemTime] 2014-12-27T01:46:28.000000000Z EventRecordID 55834 Channel Application Computer Ivana-Karaja Security
  • EventData

filezilla.exe
3.10.0.0
00000006
ntdll.dll
6.1.7601.18247
521ea8e7
c0000005
0002e3be
15ec
01d02176ee78740a
C:\Program Files (x86)\FileZilla FTP Client\filezilla.exe
C:\Windows\SysWOW64\ntdll.dll
2c5e1ff1-8d6a-11e4-b797-005056c00008

FileZilla will simply not load at all, close itself without any error message after few seconds, FileZilla main window cannot be seen.

comment:3 Changed 5 years ago by Tim Kosse

Please try the latest nightly from https://filezilla-project.org/nightly.php

comment:4 Changed 5 years ago by lostinlodos

Keywords: security memory added
Status: moreinfonew

10.3.0.0 beta 2 -> beta 3

Repeatable but issue found.
Looks like the installer is not clearing the populated memory on inplace upgrade.
A reboot solved the issue in the first place.
However on playing with the issue I found that purging the memory with various system tools also solved the problem. This points to some bits (no pun intended) of incompatible data being left in memory.
Setting the memory clear function in the installer should solve the issue.

This /could/ be a security issue if left untreated as a broken string of memory registers could be hijacked for data mining.

comment:5 Changed 5 years ago by Tim Kosse

Status: newmoreinfo

Do you mean the files on disk in the installation directory when you refer to "memory"?

comment:6 Changed 3 years ago by Kurt McKee

Resolution: outdated
Status: moreinfoclosed
Note: See TracTickets for help on using tickets.