Opened 5 years ago

Closed 2 years ago

#9861 closed Bug report (duplicate)

Don't touch APPDATA, let user to use this as a portable application

Reported by: wlclsl37 Owned by: developer
Priority: high Component: FileZilla Server
Keywords: portable Cc:
Component version: Operating system type: Windows
Operating system version: 7

Description

https://forum.filezilla-project.org/viewtopic.php?f=6&t=34184&sid=DO_NOT_TRACK_ME

Please don't touch APPDATA!
I use "FZ Server" like a portable apps.

FileZilla Server Interface.exe
FileZilla Server Interface.xml
FileZilla Server.exe
FileZilla Server.xml

Your new version break it.
If was already exist, then don't make a new folder/file to APPDATA.
Please reconsider.

Change History (3)

comment:1 Changed 3 years ago by Kurt McKee

Triage suggestion

Using FileZilla Server 0.9.60 I can confirm this behavior:

  1. FileZilla Server Interface will attempt to open FileZilla Server Interface.xml in %appdata%\Roaming\FileZilla Server.
  2. If there is no XML file in %appdata% it will look for the same file in the same directory as the FileZilla Server Interface executable.
  3. On exit, FileZilla Server Interface will write the <Item name="User Sorting"> element to %appdata%\Roaming\FileZilla Server\FileZilla Server Interface.xml. Only if the server settings changed, the last-used server settings will also be written to the %appdata% file.

In addition to harming possible portability, this causes an unfortunate behavior that the last-used server settings will be read and used on the first portable run but will be ignored on all subsequent runs because the XML file in %appdata% is favored over the local settings and only contains the "User Sorting" setting.

There are several possible ways to accommodate this feature request, if the developers would like to:

  1. Favor/prioritize the XML file in the same directory as the FileZilla Server Interface executable (and always write all configuration options to the XML file, not just those that changed).
  2. Provide a command line switch that supports specifying the path to the configuration file.

comment:2 Changed 3 years ago by Kurt McKee

Keywords: portable added

Triage suggestion

This is a duplicate of #2485.

comment:3 Changed 2 years ago by Kurt McKee

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.