Opened 5 years ago

Closed 5 years ago

#9826 closed Bug report (invalid)

Automatic Transfer Mode corrupt *.jar & *.rar files with no extension

Reported by: GamesGamble Owned by:
Priority: low Component: FileZilla Client
Keywords: transfer, mode, corrupt, jar, rar, files, extension Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 SP 1

Description

Hello,
when using the Automatic Transfer Mode FileZilla corrupts *.jar % *.rar files with no extension. I think FileZilla removed the CR (only one was present). He tried to repair things where no repair was needed. Using the Binary Transfer Mode fixes this.

Attachments (1)

FileZilla_Settings_Transfer_FileTypes.png (49.9 KB) - added by GamesGamble 5 years ago.
FileZilla>Settings>Transfer>File Types

Download all attachments as: .zip

Change History (4)

comment:1 Changed 5 years ago by Bruno Ramos

Status: newmoreinfo

Not clear that this is bug, the behavior depends on the FileZilla configuration you have set at the moment of the transfer.

Could you please show a screenshot of your "Settings..." and then "Transfers" -> "File Types" configuration? Or provide instructions with the exact configuration setup on how to reproduce this?

Thank you.

Changed 5 years ago by GamesGamble

FileZilla>Settings>Transfer>File Types

comment:2 in reply to:  1 Changed 5 years ago by GamesGamble

Priority: normallow
Status: moreinfonew

Replying to brunoramos:

Not clear that this is bug, the behavior depends on the FileZilla configuration you have set at the moment of the transfer.

Could you please show a screenshot of your "Settings..." and then "Transfers" -> "File Types" configuration? Or provide instructions with the exact configuration setup on how to reproduce this?

Thank you.

Screenshot added. It looks like FileZilla has as default setting to detect every file without any extension as ASCII... That caused this. Maybe this setting should be deactivated by default.

comment:3 Changed 5 years ago by Bruno Ramos

Resolution: invalid
Status: newclosed

My understanding is that the defaults are working as they were designed to.

And if setting binary transfers solves your "problem", there's no issue here.

I'm closing this bug report as invalid.
You can always open a feature request for the default settings change.

Thank you.

Note: See TracTickets for help on using tickets.