Opened 6 years ago

Closed 5 years ago

#9589 closed Bug report (outdated)

Windows explorer crash after installation

Reported by: Marco A. Cruz Quevedo Owned by:
Priority: normal Component: FileZilla Client
Keywords: crash, right-click, explorer shell-extension Cc: derspeckle
Component version: Operating system type: Windows
Operating system version: Win 7 32-bit

Description (last modified by Alexander Schuch)

After several years of satisfaction of an excellent product, I found the following issue in the last version: It makes Windows explorer crash when clicking right button (Win 7 32 bit) , with the following result (from event log):
---
Nombre de la aplicación con errores: Explorer.EXE, versión: 6.1.7601.17567, marca de tiempo: 0x4d6727a7
Nombre del módulo con errores: ntdll.dll, versión: 6.1.7601.18247, marca de tiempo: 0x521ea91c
Código de excepción: 0xc0000005
Desplazamiento de errores: 0x0001f9e2
Id. del proceso con errores: 0xbdc Hora de inicio de la aplicación con errores: 0x01cf8cac208c6a5f
Ruta de acceso de la aplicación con errores: C:\Windows\Explorer.EXE
Ruta de acceso del módulo con errores: C:\Windows\SYSTEM32\ntdll.dll
Id. del informe: 79185d62-f89f-11e3-a81c-eca86b715b7e
---
It makes crash with right click is used on any file. And I found that only when uninstalling AND deleting the following files BY HAND, the issue disappears:
---
fzshellext.dll
libgcc_s_sjlj-1.dll
libstdc++-6.dll
libwinpthread-1.dll
---
In fact, I selected "Uninstall " and after process finished, it asked to reboot.
Upon restart, the directory where the program was installed is full with all the files, and the issue persisted. I manually deleted all the files, but the previously mentioned were not deleted, indicating that they were used by Windows. I had to reboot to the option "Safe mode with command prompt" in order to be able to delete the files and directory.
Then, after a check with CCleaner, one key remained in registry: ---
ActiveX/COM Issue InProcServer32\
C:\Program Files\FileZilla FTP Client\fzshellext.dll
HKCR\CLSID\{DB70412E-EEC9-479C-BBA9-BE36BFDDA41B}
---
And it was deleted manually too. All the above procedure was made TWICE, because after the first time, I reinstalled the new version, hoping that it has been only a defective installation but it has not. I hope that it is corrected for the next version because it is a very useful tool.
Thank you in advance.

Change History (5)

comment:1 by Alexander Schuch, 6 years ago

Status: newmoreinfo

So which version did you try? Which is "the latest" your tried? By the way, you can install FileZilla without shell extension if that one gives you troubles on your particular setup.

comment:2 by Alexander Schuch, 6 years ago

Resolution: outdated
Status: moreinfoclosed

No reply for more than 28 days.

comment:3 by derspeckle, 6 years ago

Cc: derspeckle added
Resolution: outdated
Status: closedreopened

I can confirm this bug. It just appeared on my PC (Win 7; 32bit) with FZ V. 3.10.1.1

Name der fehlerhaften Anwendung: explorer.exe, Version: 6.1.7601.17514, Zeitstempel: 0x4ce796f3
Name des fehlerhaften Moduls: ntdll.dll, Version: 6.1.7601.18205, Zeitstempel: 0x51db96c5
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0001f9e2
ID des fehlerhaften Prozesses: 0x1cc0
Startzeit der fehlerhaften Anwendung: 0x01d046fa9505cc7c
Pfad der fehlerhaften Anwendung: C:\Windows\explorer.exe
Pfad des fehlerhaften Moduls: C:\Windows\SYSTEM32\ntdll.dll
Berichtskennung: d86a9125-b2ed-11e4-a45a-00261896e655

I disabled C:\Program Files\FileZilla FTP Client\fzshellext.dll and after that, right clicking no longer crashed my explorer.

comment:4 by Alexander Schuch, 5 years ago

Description: modified (diff)
Keywords: shell-extension added

comment:5 by Tim Kosse, 5 years ago

Resolution: outdated
Status: reopenedclosed

Please update to the most recent version of FileZilla.

Note: See TracTickets for help on using tickets.