Opened 6 years ago

Closed 6 years ago

#8929 closed Bug report (duplicate)

Fails to recognize Binary Files

Reported by: Phil Hultin Owned by:
Priority: normal Component: FileZilla Client
Keywords: Binary, Transfer Type Cc:
Component version: Operating system type: Windows
Operating system version: All

Description

This is an issue that we have observed over the past several years, but have worked around. I just figured perhaps I should inform you because the workaround is getting to be a pain.
We use Filezilla to move data folders from our Nuclear Magnetic Resonance spectrometers to individual students' and researchers' computers for data processing. These folders contain a mixture of ASCII and Binary files. When one downloads a data folder with the Transfer Type set to "Auto" the result is corrupted data, presumably because Filezilla fails to recognize the Binary files as distinct from the ASCII files. When one sets the transfer type to "Binary", everything works just fine.
The thing is, "Auto" should recognize these files and it apparently does NOT. Each year we introduce a new crop of students to using our spectrometers and the concepts of moving data and inevitably the need to switch data modes gets lost in the shuffle. I would really appreciate it if you guys could fix this.

I have attached a typical data set for you to look at.

Attachments (1)

PGH-7.zip (144.1 KB) - added by Phil Hultin 6 years ago.
NMR Data folder - zipped

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Phil Hultin

Attachment: PGH-7.zip added

NMR Data folder - zipped

comment:1 Changed 6 years ago by Alexander Schuch

Resolution: invalid
Status: newclosed

There is not much that can be done.

The files in that archive do have either no extension, or "txt", "xwp", "par" or "temp" as extension.

If you have a look in the FileZilla settings "Transfers" → "File Types", FileZilla offers a list of extensions which when present trigger an ASCII download. The option below called "Treat files without extension as ASCII files" might be what you are looking for, if you do not want to always use binary mode.

So this is not a bug, but a configuration/file nameing issue.

comment:2 Changed 6 years ago by Alexander Schuch

Resolution: invalid
Status: closedreopened

This is a duplicate of #4235.

comment:3 Changed 6 years ago by Alexander Schuch

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.