Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8849 closed Bug report (wontfix)

No Connection when connecting through a Win7-PC with "share internet connection"

Reported by: Mike Knife Owned by:
Priority: normal Component: FileZilla Client
Keywords: windows internet-sharing Cc:
Component version: Operating system type: Windows
Operating system version: Win7

Description

Setup-desciption:

Internet= [Cisco WLan-distribution-system (EAP)] =WLAN= [Win7-GW-PC] =LAN= [Internal-LAN; Work-PC(Win7)]...

Appartmenthouse-Installation with Cisco-Routers, authentication: Enterprise-AES-EAP

The Win7-GW-PC connects to the Cisco-Router through WLAN and is configured to share the internet-connection of the WLAN-interface through a second (LAN-) interface to the internal LAN

A PC connected to this LAN can do everything, even DL via Firefox-Browser like: "ftp://userid:pw@filezilla-server-address.net"

No connection can be established to the same filezilla-server using the filezilla-client. It stalls at the "211-Features" response:

.....
.....
.....
Trace: CFtpControlSocket::SendNextCommand()
Command: FEAT
Trace: CFtpControlSocket::OnReceive()
Response: 211-Features:
Trace: CRealControlSocket::OnClose(10053)
Trace: CFtpControlSocket::ResetOperation(66)
Trace: CControlSocket::ResetOperation(66)
Error: Could not connect to server
Status: Waiting to retry...
Status: Delaying connection for 1 second due to previously failed connection attempt...
Status: Resolving address of makroma-one.net
Status: Connecting to 91.67.250.131:21...
Status: Connection established, waiting for welcome message...
Trace: CFtpControlSocket::OnReceive()
Response: 220 Welcome to MAKROMA ! Be aware: This is not a public server! If you are not
Trace: CFtpControlSocket::SendNextCommand()
Command: USER makromax
Trace: CFtpControlSocket::OnReceive()
Response: 331 Password required for makromax
Trace: CFtpControlSocket::SendNextCommand()
Command: PASS
Trace: CFtpControlSocket::OnReceive()
Response: 230 Logged on
Trace: CFtpControlSocket::SendNextCommand()
Command: FEAT
Trace: CFtpControlSocket::OnReceive()
Response: 211-Features:


(Using filezilla-client on the [Win7-GW-PC] itself works fine.)

Hint: After setting debug-mode to 3 for testing and a restarting the filezilla-client just one time the directory was displayed correctly, but that could not be reproduced yet. This might have been a coincidence but leads me to the assumption that timing might be an issue here.

Mike Knife

Change History (5)

comment:1 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

Can you please use another FTP client for testing? For example try "ftp.exe" shipped with Windows and manually establish a connection, authenticate and then run the FEAT command. If even that does not reliably work, your ICS does weird stuff.

comment:2 Changed 6 years ago by Mike Knife

Status: moreinfonew

here are the test results with ftp.exe:

transcript on the GW-computer: (everything is fine)

ftp> open makroma-one.net
Verbindung mit makroma-one.net wurde hergestellt.
220 Welcome to MAKROMA ! Be aware: This is not a public server! If you are not
Benutzer (makroma-one.net:(none)): makromax
331 Password required for makromax
Kennwort:
230 Logged on
ftp> ls
200 Port command successful
150 Opening data channel for directory list.
Drive_S
Drive_W
226 Transfer OK
FTP: 18 Bytes empfangen in 0,00Sekunden 18000,00KB/s
ftp> literal feat
211-Features:

MDTM
REST STREAM
SIZE
MODE Z
MLST type*;size*;modify*;
MLSD
UTF8
CLNT
MFMT

211 End
ftp>

transcript on the PC behind the GW (via Windows 7 internet sharing)

C:\Users\MikeKnife>ftp.exe
ftp> open makroma-one.net
Verbindung mit makroma-one.net wurde hergestellt.
220 Welcome to MAKROMA ! Be aware: This is not a public server! If you are not
Benutzer (makroma-one.net:(none)): makromax
331 Password required for makromax
Kennwort:
230 Logged on
ftp> ls
200 Port command successful
150 Opening data channel for directory list.
Drive_S
Drive_W
226 Transfer OK
FTP: 18 Bytes empfangen in 0,01Sekunden 2,57KB/s
ftp> trace
Paketverfolgung EIN .
ftp> literal feat
211-Features:
Verbindung beendet durch Remotehost. (Connection closed by Remote Host)
ftp>

comment:3 Changed 6 years ago by Alexander Schuch

Resolution: wontfix
Status: newclosed

To me it looks like a problem with ICS. Maybe it does more than just NAT and actively monitors and filters the communication (FTP protocol proxy)? However, it does not seem to be a problem with FileZilla.

comment:4 Changed 6 years ago by Mike Knife

Resolution: wontfix
Status: closedreopened

Results from further testing:

LeechFTP (an older, not anymore supported client) works fine, but does not seem to issue a feat command.

SmartFTM however stops at the same point after issueing the FEAT command.

So I aggree, it does not seam to be a filezilla problem, so I appologize for utilizing your time, but:

Is this FEAT command actually necessary and if not: is there any way to suppress this command?

And:
What do you mean with ICS?
The GW-PC is a standard win7 system with "internet sharing" enabled. Deactivating the FW did not solve the problem. I am not aware of any additional filtering done by windows. As I am not an expert on this on protocoll / ip-packet level, I have no idea where I further might look at.

Thanks for your time anyway.

Mike Knife

comment:5 Changed 6 years ago by Alexander Schuch

Resolution: wontfix
Status: reopenedclosed

ICS = Internet Connection Sharing

There is no way to disable the FEAT command. Its proposal, however, is more than 15 years old. FileZilla uses it to detect the capabilities of the FTP server so that a more sane environment can be used for newer servers.

Note: See TracTickets for help on using tickets.