Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8768 closed Bug report (fixed)

FileZilla will not connect to the server in Windows 8

Reported by: Nerosas Owned by:
Priority: normal Component: FileZilla Client
Keywords: Windows 8, connection, failed, login Cc:
Component version: Operating system type: Windows
Operating system version: Windows 8

Description

I have Windows 8 64-bit on my laptop. When I try to connect to the server with the correct details, FileZilla says "Connection attempt failed with "EACCES - Permission denied".".

FileZilla connects to the server, using the EXACT same login details when I try using it with Windows 7. However I cannot use my Windows 7 computer all the time and my Windows 8 one is my main computer. The full debug report is available below.

Status: Resolving address of geographyrevision.net16.net

Status: Connecting to 31.170.161.56:21...
Status: Connection attempt failed with "EACCES - Permission denied".
Error: Could not connect to server

Change History (5)

comment:1 Changed 6 years ago by Nerosas

Whoops, I accidentally did the wrong report! Here is the debug report with the debug level set to 3:

Status: Resolving address of geographyrevision.net16.net
Status: Connecting to 31.170.161.56:21...
Status: Connection attempt failed with "EACCES - Permission denied".
Trace: CRealControlSocket::OnClose(13)
Trace: CFtpControlSocket::ResetOperation(66)
Trace: CControlSocket::ResetOperation(66)
Error: Could not connect to server

comment:2 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

Can you check your firewall or security solution settings? FileZilla does not even contact the FTP server - it is not even able to actually open the socket properly.

comment:3 Changed 6 years ago by Nerosas

Status: moreinfonew

I opened ports 20 and 21 through the Windows Firewall and the outcome was the same.

comment:4 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

Sure you allow outgoing connections? Can you do a version check for a more recent version? Is FileZilla able to connect to the update check server?

Opening ports in firewall (on Windows) usually is only required for incoming connections.

comment:5 Changed 6 years ago by Nerosas

Resolution: fixed
Status: moreinfoclosed

The problem is resolved! My laptop disabled the Windows Firewall and activated the one included with my antivirus software (all by itself, the clever thing :D ) and now FileZilla is working the way it should. So there must be something different about the Windows 8 firewall.

Note: See TracTickets for help on using tickets.