Opened 8 years ago

Closed 6 years ago

#8634 closed Bug report (outdated)

Drag and drop files not working between local and remote

Reported by: Jonathan Cross Owned by:
Priority: high Component: FileZilla Client
Keywords: mouse drag drop mac osx Cc: bugzilla@…
Component version: Operating system type: OS X
Operating system version: 10.8.3

Description

Specific issue:

Clicking on the icon of a file with left mouse button has no effect whereas it should initiate a drag.

Background:

I was prompted to update to FileZilla Client 3.6.0.2 about 9 days ago (strange because it was released 2012-11-29, perhaps I was ignoring the previous update requests, not sure). After the update, I can no longer drag / drop files between servers using left mouse button (as is normal).

Notes:

  • I can left click on filename to rename.
  • I can drag files from Mac Finder into either local or remote file lists and it works fine.
  • I can right-click to upload / download, etc.
  • Left mouse button works fine for all other applications and all dialogs, icons, etc inside FileZilla. Also works for double-click file transfer if configured for such.
  • I have restarted and even reinstalled FileZilla Client 3.6.0.2 to confirm.
  • I looked in Preferences and did not see anything obvious that could cause this behavior. Tried every conceivable option that could trigger changes to mouse behavior in file list.
  • Using a standard 2-button logitech mouse with scroll wheel. Have tries with another generic mouse and exact same behavior.

Research:

  • I tried to first check the FileZilla help forum for related threads. Did not find any.
  • I did not find any open bugs for this.
  • I attempted to register on the help forum to see if I was just missing something, but the forum does not accept @gmail.com addresses. [no comment]

About FileZilla:

FileZilla Client
----------------

Version:          3.6.0.2

Build information:
  Compiled for:   i686-apple-darwin9
  Compiled on:    i386-apple-darwin9.8.0
  Build date:     2012-11-29
  Compiled with:  i686-apple-darwin9-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5577)
  Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:
  wxWidgets:      2.8.12
  GnuTLS:         3.1.3
  SQLite:         3.7.6.2

Operating system:
  Name:           Mac OS X (Darwin 12.3.0 x86_64)
  Version:        16.131

Change History (2)

comment:1 by lourdas_v, 7 years ago

Cc: bugzilla@… added

I have the same issue. I'm using Filezilla 3.7.3 in x64_64 Linux. If I choose one file and drag it to the remote host, nothing happens. If I choose 2 files and drag them, only one of them is uploaded. 3 files and 2 of them uploaded. It's always n-1 files uploaded for a selection of n files.

FileZilla Client
----------------

Version:          3.7.3

Build information:
  Compiled for:   x86_64-pc-linux-gnu
  Compiled on:    x86_64-pc-linux-gnu
  Build date:     2013-10-03
  Compiled with:  x86_64-pc-linux-gnu-gcc (Gentoo 4.7.3-r1 p1.3, pie-0.5.5) 4.7.3
  Compiler flags: -O2 -pipe -march=core2 -mcx16 -msahf -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -mno-sse4.2 -msse4.1 -mno-lzcnt -mno-rdrnd -mno-f16c -mno-fsgsbase --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=core2 -Wall -fexceptions -std=gnu++11

Linked against:
  wxWidgets:      2.8.12
  GnuTLS:         2.12.23
  SQLite:         3.7.17

Operating system:
  Name:           Linux 3.11.3-gentoo x86_64
  Version:        3.11

comment:2 by Bruno Ramos, 6 years ago

Resolution: outdated
Status: newclosed

Tested under Debian GNU/Linux with the latest version of FileZilla and it is working successfully.

Please reopen ticket if issue still happening to you in latest version of FileZilla.

Note: See TracTickets for help on using tickets.